Table has extra columns after hover sets td overflow:visible and float:left or postion:absolute

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: spam_from_bugzilla, Assigned: bzbarsky)

Tracking

({testcase})

Trunk
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)

I have a table which sets td {white-space:nowrap; overflow:hidden;} so that large cells are truncated. I want td:hover to reveal the full contents of the cell.  td:hover {overflow:visible} almost does what I want, but the new content is superimposed over the neighbouring cell.  {overflow:visible; background-color:white} of course doesn't work because the background doesn't extend under the overflow.  So I tried this:

td {
  white-space: nowrap;
  overflow: hidden;
}

td:hover {
  overflow: visible;
  background-color: something...;
  float: left;  OR  postion:absolute;
}

The float or absolute puts the background under all of the td content, including the overflow.  This does what I want, except for this odd bug:

It seems as if, when the hover reveals the overflowed content, the cells to the right of the hovered-over cell get shifted to the right.  It's not a shift by a number of pixels, but rather a shift by a number of columns; the table gains new columns to its right.

I'll attach a test case.  As you'll see it's from a webmail application.  Just move the mouse around over the table to trigger the hovers and see the extra columns attach themselves.  If you don't immediately see what I mean I can attach a screenshot.

Sorry, I expect to hear that this is a dupe, but searching for the obvious keywords didn't find anything.

This is with Firefox 1.5 on Debian.


Reproducible: Always
(Reporter)

Comment 1

13 years ago
Posted file Testcase
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060526 Minefield/3.0a1 - Build ID: 0000000000
Confirmed. How odd.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Posted file Frame dump
We're leaving behind a pseudo cell (red)...
Depends on: 162063
Keywords: testcase
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 4

13 years ago
Thanks for the analysis Mats.

Can ayone suggest an alternative way of getting the effect that I was looking for?
Attachment #224507 - Attachment description: Testcase #3 → Testcase #3, abs.pos.
Fixed by checkin for bug 162063.  Added test.
Assignee: nobody → bzbarsky
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.