Closed Bug 339588 Opened 18 years ago Closed 18 years ago

Firefox start up takes 75 sec when history.dat file is 74MB

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 223476

People

(Reporter: compute33, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Deleting the 74MB history.dat file fixes the consistently slow (75 sec) startup. 

Reproducible: Always
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060529 Minefield/3.0a1

See "Bug 279342 big history.dat file kills menubar pulldown performance"
Firefox 3.0 (in the future) is supposed to be a lot better, becuase it uses a database instead of a textfile.

*** This bug has been marked as a duplicate of 223476 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
I'm curious how Places works with a history the size of yours. If you want, can you try a trunk nightly? You can also wait for Firefox 3 a1 which will probably come out in a month or two. Generally, performance with large histories is improved, but I'm not so sure about one as big as yours. I'd be interested in hearing about your experience.

Trunk first-run performance will be terrible for you because it will import your history file. But after that if places performance is still unacceptable, please file a new bug under the Firefox|Places component.
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.