Missing space between "License" and "document" in about:

RESOLVED DUPLICATE of bug 328563

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 328563
12 years ago
12 years ago

People

(Reporter: dolphinling, Assigned: dolphinling)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1011 bytes, patch
Benjamin Smedberg
: review+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
http://lxr.mozilla.org/mozilla/source/toolkit/content/about.xhtml#97

Line 97 reads 
  <a href="about:license">Mozilla Public License &license.and; Netscape Public License</a>&license.part3;

There needs to be a space after the </a>
(Assignee)

Comment 1

12 years ago
Created attachment 223752 [details] [diff] [review]
patch

Patch. Untested. :) Hope I guessed right about who to request review from.

Apparently the word "document" was added since the 1.8 branch, so this patch would only apply to trunk. Another fix would be to edit the dtd with the entities to have a space in that string.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #223752 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #223752 - Flags: review? → review?(steffen.wilberg)
(Assignee)

Comment 2

12 years ago
Since I may not have been clear before:
The about: page, when viewed, reads "... Netscape Public Licensedocument. All Rights Reserved." License is hyperlinked and document is not, but there still needs to be a space between them.
(Assignee)

Comment 3

12 years ago
Part of comment 1 is wrong: this applies to the 1.8 branch as well as the trunk (but not the 1.8.0 branch).

Comment 4

12 years ago
In bug 328563 comment 1, Gerv said:
> I didn't know about the existence of this (about:) page. Really, all licensing
> information (including those sentences and the NPL reference) needs to be
> removed, and replaced with a single link to about:licence.
That's what bug 328563 is about (if not removing about: altogether). Feel free to take that bug.

And I only do reviews in Firefox Help Documentation. benjamin@smedbergs.us would be appropriate.
(Assignee)

Comment 5

12 years ago
Comment on attachment 223752 [details] [diff] [review]
patch

I won't take bug 328563 because I'd have no clue what to do with it. If people want this to just be part of that, fine.
Attachment #223752 - Flags: review?(steffen.wilberg) → review?(benjamin)

Updated

12 years ago
Attachment #223752 - Flags: review?(benjamin) → review+

Comment 6

12 years ago
The linked document (about:license) doesn't take you to a "Mozilla Public License and Netscape Public License document". That document contains all the relevant licenses, but the NPL isn't one of them anymore.
(Assignee)

Comment 7

12 years ago
Page was redone (in bug 328563), this bug now irrelevant. 

*** This bug has been marked as a duplicate of 328563 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.