Closed Bug 339710 Opened 14 years ago Closed 14 years ago

Can't use "Go" button" with using keyword or space

Categories

(Firefox :: Toolbars and Customization, defect, P1)

2.0 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 2 beta1

People

(Reporter: 093236, Assigned: Gavin)

References

Details

(Keywords: regression, verified1.8.1)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060530 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060530 BonEcho/2.0a3

When I enter the keyword or something that has space in location bar then click/middle click the "Go" button, browser cannot go to the page and just show an alert that is "The URL is not valid and cannot be loaded"

Reproducible: Always

Steps to Reproduce:
1.Enter the keyword or something that has space in location bar 
2.Click/Middle click the "Go" button
3.

Actual Results:  
Browser cannot go to the page and just show an alert that is "The URL is not valid and cannot be loaded"

Expected Results:  
Go to the page that using the keyword or search the word of the website that you have type
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regression between 1.9a1_2006052901 and 1.9a1_2006052912.
Blocks: 279687
Flags: blocking-firefox2?
gah, right, that'll sting a little.
Assignee: nobody → gavin.sharp
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: --- → Firefox 2 beta1
Status: NEW → ASSIGNED
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Version: unspecified → 2.0 Branch
Attached patch patch (obsolete) — Splinter Review
This makes openUILink take a third arg for allowFixup (without affecting any existing callers that omit it), and makes the allowFixup parameter to openUILinkIn work for the "current" case.
Attachment #223858 - Flags: review?(mconnor)
Comment on attachment 223858 [details] [diff] [review]
patch

keyword search still don't work with this
Attachment #223858 - Attachment is obsolete: true
Attachment #223858 - Flags: review?(mconnor)
*** Bug 340703 has been marked as a duplicate of this bug. ***
Attached patch patch (obsolete) — Splinter Review
I couldn't help doing a bit of cleanup, I tried to restrict myself to the stuff I was touching :). This patch:
- Lets handleURLBarCommand handle the go button and location bar events
- Uses openUILinkIn for mouse events, and the BrowserLoadURL for key events (as before)
- Adds some optional parameters to openUILink to make it handle bookmark keywords with postData and keyword.url fixup
Attachment #226474 - Flags: review?(mconnor)
Whiteboard: [patch-r?]
Comment on attachment 226474 [details] [diff] [review]
patch


>-  }
>-  else  
>+  } else
>     loadURI(url, null, aPostData, true /* allow third party fixup */);
>+

we're moving to the old style, don't change this :P

>-function openUILinkIn( url, where, allowThirdPartyFixup )
>+function openUILinkIn( url, where, allowThirdPartyFixup, postData )
> {
>-  if (!where)
>+  if (!where || !url)
>     return;
> 
>-  if ((url == null) || (url == "")) 
>-    return;
>   // xlate the URL if necessary
>-  if (url.indexOf("urn:") == 0) {
>-      url = xlateURL(url);        // does RDF urn expansion
>-  }
>+  if (url.indexOf("urn:") == 0)
>+    url = xlateURL(url);        // does RDF urn expansion
>+
>   // avoid loading "", since this loads a directory listing
>-  if (url == "") {
>-      url = "about:blank";
>-  }
>+  if (url == "")
>+    url = "about:blank";

you'll never hit this if url == ""  I love that the old code explicitly checked this earlier and returned
Attachment #226474 - Flags: review?(mconnor) → review+
Attached patch for checkinSplinter Review
Discussed this with mconnor on IRC, turns out xlateURL isn't even defined, so I just removed that entire block.
Attachment #226474 - Attachment is obsolete: true
mozilla/browser/base/content/utilityOverlay.js 	1.38
mozilla/browser/base/content/browser.xul 	1.310
mozilla/browser/base/content/browser.js 	1.652
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [patch-r?] → [need-a]
Comment on attachment 227085 [details] [diff] [review]
for checkin

This fixes a regression from bug 279687, which landed on the branch. The only change in behavior that it introduces is for clicks on the Go button, so the chance that it will cause a regression is relatively low.
Attachment #227085 - Flags: approval1.8.1?
Whiteboard: [need-a] → [a?]
Attachment #227085 - Flags: approval1.8.1? → approval1.8.1+
Whiteboard: [a?] → [checkin needed (1.8 branch)]
mozilla/browser/base/content/browser.js 	1.479.2.157
mozilla/browser/base/content/browser.xul 	1.268.2.46
mozilla/browser/base/content/utilityOverlay.js 	1.32.2.8
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
Depends on: 343603
v. verfied fixed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b2) Gecko/20060829 BonEcho/2.0b2
Status: RESOLVED → VERIFIED
Depends on: 405541
You need to log in before you can comment on or make changes to this bug.