Should highlight url on select

VERIFIED DUPLICATE of bug 19217

Status

()

P3
enhancement
VERIFIED DUPLICATE of bug 19217
19 years ago
19 years ago

People

(Reporter: mzajonc, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    2000033008

I have a ui suggestion that I think is simple but very important.  When you 
click on the url field it should automatically select the current url so that 
one can immediately start typing and overwrite the existing url. Presently you 
must click on the field, then move the mouse with a button down to select the 
field and THEN type the new url.  This is very annoying. Both MSIE and Netscape 
work like I propose.  There is no reason not to have it be like this.

Reproducible: Always
Steps to Reproduce:
1. Click on url field
2.  Note that it doesn't select the field text so that typing will overwrite.  
Instead it inserts.



Actual Results:  See above...


Expected Results:  See above..

Comment 1

19 years ago
If this is done it should definitely be preffed - because I hate that about IE.
It's probably the one thing that annoys me most. I often want to edit the URL,
and if I do want to replace it, I'll double-click (as you can now) to select the
whole thing.

I will confirm that we don't currently do what you want though.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
Known Selection bug. 

I don't know offhand what bug # this is a duplicate of.
Assignee: bdonohoe → mjudge
Component: User Interface: Design Feedback → Selection
(Reporter)

Comment 3

19 years ago
Ok.   Doubleclick does what I was talking about.  Thanks puetzk.  I still think 
that it should be switched to the other order as default.  One click selects, 
two clicks edits.  This is how other browsers do it and it seems to make 
sense.  More often than not one is going to a new site not changing an existing 
url.

Comment 4

19 years ago
mzajonc@pomona.edu, I agree with you 100% --- exactly the behavior you're 
specifying is what Mozilla should (and will) be doing. It just hasn't been 
implemented yet.

Comment 5

19 years ago
elig : is this a dup of bug #19217 ? (auto select on click in URL bar).

Comment 6

19 years ago


*** This bug has been marked as a duplicate of 19217 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
OS: Windows 98 → All
Hardware: PC → All
Resolution: --- → DUPLICATE

Comment 7

19 years ago
setting milestone, this needs to be verified
Target Milestone: --- → M15

Comment 8

19 years ago
Thanks, John!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.