Multiple page table does not print correctly in Firefox 1.5.0.3 on Windows XP

RESOLVED DUPLICATE of bug 294991

Status

()

Core
Printing: Output
--
major
RESOLVED DUPLICATE of bug 294991
12 years ago
11 years ago

People

(Reporter: Alder Locke, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Attempting to print a web page, W3C validated XHTML, with a level one header, and introduction paragraph, a long data table, and a summary paragraph.

Reproducible: Always

Steps to Reproduce:
1. View the attached testcase in Firefox 1.5.0.3
2. Select File -> Print...
3. Ensure that "Print Range" is set to "All" to print all pages
4. Click "OK"

Actual Results:  
On the first page, the header and intro paragraph print, followed by white space to the page break.  The second page contains the first page of the data table (correct behavior).  The third page prints the summary paragraph only; the rest of the data table is never printed.

Expected Results:  
The first page should print the header, intro paragraph, and the beginning of the data table.  The table should continue on subsequent pages, followed by the summary paragraph.

== Build and Platform ==
Windows XP SP2
Firefox version 1.5.0.3 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3]

== Page Setup ==
Orientation: Portrait
Scale: 100%
Do not shrink to fit page width
Do not print background colors and images
Top Margin: 0.5
Left Margin: 0.5
Right Margin: 0.5
Bottom Margin: 0.5
Header: Title –blank—URL
Footer: Page # of # --blank—Date/Time

== Additional Builds ==
- Also occurs from:
Minefield 3.0a1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060531 Minefield/3.0a1]

- Prints properly from:
Internet Explorer [6.0.2900.2180.xpsp_sp2_gdr.050301-1519]
Netscape 8.1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20060127 Netscape/8.1] – In Internet Explorer render mode

- Prints all of data table, but still has white space between intro paragraph and table from:
Firefox 1.0.8 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060410 Firefox/1.0.8]
Netscape 8.1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20060127 Netscape/8.1] – In Firefox render mode
Mozilla [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060414]

== Real-world Examples ==
These may change, so it may be better to view the attached test case.
http://www.doj.mt.gov/driving/driverexamstations.asp
http://www.doj.mt.gov/svor/reportoffenderlocation.asp
http://www.mt.gov/govt/statedir/agency/doa.asp
http://www.mt.gov/govt/statedir/agency/justice.asp
(Reporter)

Comment 1

12 years ago
Created attachment 223970 [details]
Simple test case
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
- Also occurs from:
Firefox 1.5.0.4 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4]

Comment 3

12 years ago
Created attachment 235415 [details]
Files describing incorrect printing of long tables with css "clear" triggering the problem

Error verified on FF 1.5.0.6 and trunk build of Aug 25 2006.

http://www.slaktdata.org/test/ also has a copy of the test case
(Reporter)

Comment 4

12 years ago
Please note, my additional "Simple test case" has no css at all.

I don't believe this print bug is css related, however there may be another bug that you are experiencing.  

You might test this theory by looking at your test case with no css applied.

(In reply to comment #3)
> Created an attachment (id=235415) [edit]
> Files describing incorrect printing of long tables with css "clear" triggering
> the problem
> 
> Error verified on FF 1.5.0.6 and trunk build of Aug 25 2006.
> 
> http://www.slaktdata.org/test/ also has a copy of the test case
> 

Comment 5

11 years ago
There are many similar bug reports and in fact the bug is as old as I can think about it. Essentially, some table data is lost when printing. Duping this to a confirmed bug which is rather general. If you are sure that it is different, please undo.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294991
You need to log in before you can comment on or make changes to this bug.