MailView on custom header not working after 338310's patch

VERIFIED FIXED

Status

MailNews Core
Backend
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: Bienvenu)

Tracking

({fixed1.8.1, regression})

Trunk
x86
Windows 2000
fixed1.8.1, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.08 KB, patch
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Spun off from bug 338310, which implemented the ability to search in a folded header for Search Messages and Filters (currently only on the trunk, since 
0524).  As noted at bug 338310 comment 8, in my testing, versions at least 
since TB 1.5 have been able to do that successfully in MailViews.  (I also see 
at least one case of this already working with Message Filters in TB 1.5.)

However, since the fix for that bug, the behavior of MailViews has regressed:
Now, a view based on a custom header (e.g., Content-Type or X-Spam-Status)
doesn't work at all -- even if the searched-for test appears in the first line
of the header.

TB 3a1-0529, Win2K

Works as expected with TB 3a1-0520, 2a1-0523, 1.5.

A useful test case for me would be to create a MailView on:
  Content-Type, contains, boundary


See also bug 209488 comment 4: this points out a couple possible trip-ups here when MailView'ing on custom headers:
 - with match mode "is" it never matches
 - with match mode "contains" it matches *any* header containing the substring

That would be worth fixing too.
(Reporter)

Comment 1

12 years ago
I don't know what has happened in the past fifteen minutes, but I can no longer reproduce any part of this bug.  If I figure it out, I'll reopen it.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

12 years ago
OK, reopening.  The problem was: I was double-checking the test case about looking at 'boundary' in Content-Type -- to make sure I wasn't seeing cross-header matches (as in bug 209488), I set the match string to:
  boundary="
That extra quote caused the entire criterion to be dropped off the end of mailviews.dat (bug 103658).

Resetting to the original criterion, all of comment 0 is again reproducible.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 3

12 years ago
I'm unconvinced that the fix for bug 338310 is the direct cause of this, though the code changed is the code that's failing. I was able to reproduce this problem with a 2.0 build, and 2.0 doesn't have the fix for bug 338310 - does this bug happen with a 2.0 build for you, Mike?
Assignee: nobody → bienvenu
Status: REOPENED → NEW
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> does this bug happen with a 2.0 build for you, Mike?

No, I don't see this.  I just got 2a1-0601 and MailViews still work as 
expected.
(Assignee)

Comment 5

12 years ago
ah, you're right - I'm still getting the hang of x-code, and I left a letter out in the path to the executable, so I was running the wrong executable.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

12 years ago
Created attachment 224447 [details] [diff] [review]
proposed fix

when cloning the terms from the view, we weren't copying the custom header attribute, so when we execute the search, there was no custom header value. This problem had nothing to do with the fix for bug 338310, as near as I can tell, but I don't know specifically what caused this problem.
Attachment #224447 - Flags: superreview?(sspitzer)
Comment on attachment 224447 [details] [diff] [review]
proposed fix

sr=sspitzer, acting sr for mailnews while mscott is away
Attachment #224447 - Flags: superreview?(sspitzer) → superreview+
(Assignee)

Comment 8

12 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

12 years ago
V with TB 3a1-0606, Win2K
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

12 years ago
fixed for 2.0, along with bug 338310
Keywords: fixed1.8.1
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.