Inspired by http://zestyping.livejournal.com/193260.html ... I think we should replace the "performance" keyword with "speed" and "memuse" keywords, to make it more clear what it means and to avoid discouraging people from using a keyword on memory use bugs.
<dveditz> Jesse_: why not leave "perf" (for speed) and add "bloat" <dveditz> I suppose bloat could be other than memory, but generally that's what we use it to mean <Jesse> bloat for memory use, and footprint for code size? <Jesse> i'd rather use clear, precise terms (speed, memory use, code size) rather than jargony, ambiguous terms (perf, bloat, footprint) <dveditz> fair enough... but the "jargony" ones are pretty ingrained <Jesse> it's not that hard to switch from using "perf" to using "speed" <dveditz> yeah.. bloat vs memory use would be a harder battle <dveditz> just on length alone :-) <Jesse> memuse? <dveditz> bloat is less ambiguous -- too much memory use, not some other memory use issue <gavin_> memuse sounds like it would get abused for everyone's "memory leak" bugs <Jesse> so it should be "bloat" to distinguish it from "mlk"? <dveditz> I guess I'm just fond of the term "bloat" <dveditz> and like gavin I worry memuse might get used for mlk... but I guess I don't care all that much <dveditz> "bloat" doesn't exist, so you can call it whatever you want. Changing "footprint" is going to confuse people, and your alternative is maybe not enough better to be worth it <dveditz> ditto perf vs speed
When consensus is reached I can make this change.
Status: NEW → ASSIGNED
See also bug 309374, a wontfixed bug that asked for a "memoryuse" keyword.
Summary: Replace "performance" keyword with "speed" and "memuse" keywords → Replace "perf" keyword with "speed" and "memuse" keywords
(In reply to comment #3) > See also bug 309374, a wontfixed bug that asked for a "memoryuse" keyword. > So that is out the door. That leaves only one half of this bug the part about "speed", which would still be an improvement over current situation. Then again, there is startup speed, rendering speed, tab switch speed, refresh speed, etc.
Any updates on this bug? Sounds like consensus still hasn't been reached.
See also bug 397822, about fixing the descriptions of the existing keywords.
Now that bug 397822 is fixed, we seem to be in agreement about how the current keywords ("perf", "footprint", and "mlk") are used. They all have multiple meanings to some extent, but I think only "footprint" should be split. They're all a bit jargony for new bmo users, but I don't know if renaming them is worth the cost to long-time bmo users. * "perf": speed (both throughput and responsiveness) * Splitting "perf": The distinction between a "throughput" bug and a "responsiveness" bug often has more to do with the expected fix than the bug itself. (Will the patch fix the problem by making the computation more efficient, or will it fix the problem by making it interruptible or by putting it on another thread?) I wouldn't expect many users to care about the distinction either. I think it should remain as a single keyword. * Renaming "perf": I'd like to see this keyword renamed to "speed" for the reasons given by Ka-Ping Yee (see the link in comment 0). It would be easier for bmo newbies to understand and they wouldn't have to wonder what "perf" stands for. * "footprint": memory use (both code size and runtime allocations) * Splitting "footprint": There's a clear split between "excessive code size" bugs and "excessive runtime allocation" bugs; they require completely different types of fixes. Even though both types of bugs have the same effect on users (Firefox needs more RAM), I think splitting it into two keywords would make sense. * Renaming "footprint": Changing to "memuse" (perhaps along with "codesize") would make it shorter, but I don't know if it would help understandability. * "mlk": memory leaks (both never-released and not-released-until-shutdown) * Splitting "mlk": The effect on users is exactly the same. The distinction is sometimes useful to developers, in that not-released-until-shutdown are harder to discover and require different types of fixes. I think it should remain as a single keyword. * Renaming "mlk": Changing this keyword to "leak" would make it slightly easier for bmo newbies to understand what the keyword means, and would make it a bit easier to search for leak bugs with QuickSearch.
Summary: Replace "perf" keyword with "speed" and "memuse" keywords → Rename and/or split performance-related keywords
dbaron is in favor of adding a "codesize" keyword and leaving the rest as-is.
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
I can add the codesize keyword and close this if a description is provided. Is this still needed? dkl
closing bug due to inactivity. please re-open this bug if still relevant.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.