Last Comment Bug 340119 - [FIX]Changing print preview settings makes <noscript> tags appear
: [FIX]Changing print preview settings makes <noscript> tags appear
Status: VERIFIED FIXED
: fixed1.8.0.5, fixed1.8.1
Product: Core
Classification: Components
Component: Print Preview (show other bugs)
: Trunk
: x86 All
: P1 normal (vote)
: mozilla1.9alpha1
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
: 340145 (view as bug list)
Depends on:
Blocks: 342439
  Show dependency treegraph
 
Reported: 2006-06-02 09:18 PDT by Boris Zbarsky [:bz]
Modified: 2006-07-08 15:51 PDT (History)
5 users (show)
dveditz: blocking1.8.0.5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Maybe this will make life better? (2.46 KB, patch)
2006-06-02 09:30 PDT, Boris Zbarsky [:bz]
jonas: review+
jonas: superreview+
Details | Diff | Review
1.8 branch version (2.46 KB, patch)
2006-06-02 09:51 PDT, Boris Zbarsky [:bz]
jonas: approval‑branch‑1.8.1+
dveditz: approval1.8.0.5+
Details | Diff | Review

Description Boris Zbarsky [:bz] 2006-06-02 09:18:00 PDT
See bug 334944 comment 20.

At a guess, someone somewhere is calling TurnScriptingOn _again_ on every single change.  It's not clear whether the right fix is to change that inane behavior or to change TurnScriptingOn to work around it.
Comment 1 Boris Zbarsky [:bz] 2006-06-02 09:22:06 PDT
OK, the print preview UI is just on complete crack and runs PrintPreview() every single time something changes.  Without tearing down the old preview, from what I can see.

I guess we get to work around this in TurnScriptingOn... :(
Comment 2 Boris Zbarsky [:bz] 2006-06-02 09:30:18 PDT
Created attachment 224204 [details] [diff] [review]
Maybe this will make life better?
Comment 3 Doron Rosenberg (IBM) 2006-06-02 09:47:39 PDT
tested on trunk windows firefox debug and this fixed the testcase for me.
Comment 4 Boris Zbarsky [:bz] 2006-06-02 09:50:18 PDT
Comment on attachment 224204 [details] [diff] [review]
Maybe this will make life better?

sicking, could you review?
Comment 5 Boris Zbarsky [:bz] 2006-06-02 09:51:08 PDT
Created attachment 224207 [details] [diff] [review]
1.8 branch version
Comment 6 Tracy Walker [:tracy] 2006-06-02 12:16:19 PDT
*** Bug 340145 has been marked as a duplicate of this bug. ***
Comment 7 Boris Zbarsky [:bz] 2006-06-02 13:31:58 PDT
Fixed on trunk and 1.8 branch.
Comment 8 Daniel Veditz [:dveditz] 2006-06-06 14:31:44 PDT
Comment on attachment 224207 [details] [diff] [review]
1.8 branch version

approved for 1.8.0 branch, a=dveditz for drivers
Comment 9 Boris Zbarsky [:bz] 2006-06-06 16:25:33 PDT
Fixed on the 1.8.0 branch.
Comment 10 Tracy Walker [:tracy] 2006-06-12 09:28:28 PDT
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060612 BonEcho/2.0a3

Note You need to log in before you can comment on or make changes to this bug.