Crash on exit after opening/closing Options dialog [@ntdll.dll + 0x10f29 (0x7c910f29) cf2c2a54]

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({crash, regression})

2.0 Branch
Firefox 2 beta1
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
seen on Bon Echo nightly build from 20060602

-Launch application
-Open Tools | Options
-Click on a couple varios categories
-Close Options dialog
-exit application

crash

talkback incidents: (Talkback cruncher currently 5600 incidents behind)
19424750
19424717
(Reporter)

Updated

12 years ago
Flags: blocking-firefox2?
(Reporter)

Comment 1

12 years ago
Narrowed this down to Privacy category.  Click on it and we crash once we exit the app. It doesn't matter how you leave the dialog. Once Privacy category has been opened it's crash time...  and once you've clicked Privacy and left the dialog with it selected, you can't get away from it on restart. Reopen OPtions and privacy is already selected (expected) the click to General.  exit App. ...crash.  restart and open Options.  the crash made it forget General was last selected.  Privacy is selected... we're stuck crashing after anytime we go into Options and exit the app.  Only way out, once this state has beenm attained, is to wipe the profile.
(Reporter)

Comment 2

12 years ago
many crash bugs in ntdll.dll and plenty of recent crashes in : ntdll.dll + 0x10f29 (0x7c910f29) cf2c2a54 specifically.
Summary: Crash on exit after opening/closing Options dialog → Crash on exit after opening/closing Options dialog [@ntdll.dll + 0x10f29 (0x7c910f29) cf2c2a54]
This is probably related to bug 339861, which seems to be crashes when form history code is invoked (caused by bug 335558). The reason I think this is related is because opening the Privacy tabs invokes the form history code (to find out if the "clear form history" button should be enabled).
Depends on: 339861
+ in case 339861 is not the sole culprit.
Flags: blocking-firefox2? → blocking-firefox2+

Updated

12 years ago
Target Milestone: --- → Firefox 2 beta1
(Reporter)

Comment 5

12 years ago
no longer crashing in: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060612 BonEcho/2.0a3.

marking wfm, (probably fixed by bug 339861 and/or bug 335558.

Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Flags: blocking-firefox2+
(Assignee)

Updated

7 years ago
Crash Signature: [@ntdll.dll + 0x10f29 (0x7c910f29) cf2c2a54]
You need to log in before you can comment on or make changes to this bug.