Last Comment Bug 340208 - unable to add discovered search plugin from url with non-standard http port number
: unable to add discovered search plugin from url with non-standard http port n...
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: 2.0 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Florian Quèze [:florian] [:flo]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-02 22:02 PDT by Mukunda
Modified: 2006-06-03 04:41 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mukunda 2006-06-02 22:02:19 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

I tried adding a search plugin (via link rel=search tag) using OpenSearchDescription (Also tried MozSearch)

Although the plugin is detected and added to the search drop-down list, I get an error when selecting "Add My Search" from the menu.

I suspect that the problem is caused by the fact that the search plugin is hosted on localhost:21420 (It may be either the localhost or the non-standard port that causes the problem)

I have a local web server running on http://localhost:21420/ and the osd.xml file is being requested, detected properly, but not added.

The error message is as follows:

"Bon Echo could not download the search plugin from:
 http://localhost:21420/lib/osd.xml"

I also get the same error when using a MozSearch plugin copied from mozdev:

http://developer.mozilla.org/en/docs/Creating_MozSearch_plugins

I used the last example on that page, copied exactly so that I would not introduce any errors in the code that might cause a problem. I can't see anything wrong here other than the fact that it is served locally and from a non-standard port number.

Reproducible: Always

Steps to Reproduce:
1. load a page with link rel='search' href='http://localhost:21420/osd.xml'
2. click the down-arrow next to search bar
3. select 'add (search plugin title)'
4. failure!
Actual Results:  
Popup error:
"Bon Echo could not download the search plugin from:
 http://localhost:21420/lib/osd.xml"

Expected Results:  
Plugin added to search
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-06-02 22:12:19 PDT
Can you set browser.search.log to true using about:config, and paste the log in this bug? You can check either stdout or the Error Console (you may want to clear it first because it gets pretty full with that logging enabled).
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-06-02 22:15:31 PDT
Does the same definition file work if you try to install it from a "normal" location? Can you attach your osd.xml here?
Comment 3 Mukunda 2006-06-03 04:41:19 PDT
ok, I figured it out. this is not really a bug (except for the lousy error message)

The reason I though that it was a bug is because I tried two different search description files. One was copied from a working example, however, when I copied the code, the processing instruction < ?xml version="1.0"? > and xmlns="http://a9.com/-/spec/opensearch/1.1/" were left out. Firefox does not show that part of the xml when viewing an xml file (I should have done a view-source, my mistake!)

Anyway, this is the example that I used, and eventually I got it to work by adding the namespace and xml processing instruction:

http://technorati.com/osd.xml

A second search description file that I tried was the example from developer.mozilla.org wiki. I thought that the example should have worked, however, there was an error in the code on the wiki - it had an ampersand unescaped in the url template. I have updated the wiki example so that this doesn't cause more confusion.

In my openion, the error message could be more helpful [since it says "unable to download" but in this case it was parse/validation error that caused it to fail, even though it read the file well enough to add it to the menu]

I appreciate the input and I'm sorry for filing a bogus report. It's working fine now. Maybe someone will get a chance to make a more helpful error message that hints at the cause of failure. I might be able to do it but I'm not familiar with the mozilla source code. I might search for the relevant source code and make a patch if I get ambitious.

By the way, thanks for pointing to the browser.search.log preference, I assume that it would have helped if I would have read about it before solving this through trial and error :)


Note You need to log in before you can comment on or make changes to this bug.