Double click on ftp link hangs Firefox

RESOLVED DUPLICATE of bug 332730

Status

()

P1
critical
RESOLVED DUPLICATE of bug 332730
13 years ago
13 years ago

People

(Reporter: jmjeffery, Assigned: darin.moz)

Tracking

({regression})

Trunk
mozilla1.9alpha1
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060602 Minefield/3.0a1,Firefox
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060602 Minefield/3.0a1,Firefox

Double click of ftp link hangs Firefox.

Reproducible: Always

Steps to Reproduce:

1. Double-click the bookmark (as if you got itchy with the trigger finger)
2. Note that two tabs Open to the ftp site but only one loads
3. click on any folder to examine the contents
4. click the back button and select another folder
5. the folder does not open, in fact no other folder will open
6. Minefield appears to be locked out from communicating with any other tabs you have open
7. Close Minefield, and check the taskmanager - Note - Firefox.exe does not close. 
Actual Results:  
2nd tab never loads, Firefox stops browsing and no other open tabs will load/refresh. Closing Firefox results in firefox.exe still running in the TaskManager Process Tab.



Expected Results:  
2nd Tab should load and Firefox should not hang. 

I've only tested in Minefield.  Unknown if this also affects 1.5.0.x series or Bon Echo 2.0
It looks like this is the same in branch, only in trunk an alert is missing: 
421 There are too many connections from your internet address.
When I click OK, the first tabs still loads, the other tabs gets [Untitled] and stops loading. 
I believe this is the regression range: 1.9a1_2006022812 - 1.9a1_2006022822.
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-02-28+11%3A00&maxdate=2006-02-28+23%3A00

Bug 312760 is about FTP.
Blocks: 312760
Component: General → Networking
Product: Firefox → Core
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → networking
What tab(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20060602 Minefield/3.0a1,Firefox
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20060602 Minefield/3.0a1,Firefox
> 
> Double click of ftp link hangs Firefox.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 
> 1. Double-click the bookmark (as if you got itchy with the trigger finger)
> 2. Note that two tabs Open to the ftp site but only one loads

What tab related extensions do you have installed and what non-default open in tabs options do you have selected?

I am unable to reproduce any of this using the same build.

I do not even get 2 tabs open on the double click.  I can click rapidly hundreds of times on this link on the bookmarks toolbar and only ever get one window with one tab. I also ahve no issue with opening any folder after going back.
(Assignee)

Comment 4

13 years ago
-> me
Assignee: nobody → darin
Priority: -- → P1
Target Milestone: --- → mozilla1.9alpha
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Keywords: regression
(Assignee)

Comment 5

13 years ago
This appears to actually be a duplicate of bug 332730.  The changes in bug 312760 probably just caused it to get exercised more easily whereas previously it was much less likely to be hit.

*** This bug has been marked as a duplicate of 332730 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.