Status

()

defect
RESOLVED DUPLICATE of bug 97284
13 years ago
13 years ago

People

(Reporter: 3umphant, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

There is a technology in IE, that gives to make RTE from div-element.
It's enabling by writing the following code in javascript:
document.designMode = "On";
document.all("divID").contentEditable = true;
In IE it makes editable only the content of DIV-element. In gecko document.designMode="On" makes all the document to be editable. And "contentEditable" 'caurse isn't work.

Is there some way to make only div to be editable. It works in IFRAME, but by the different reasons, such as multy-browser formating problems and difficulties of event handling in IFRAME, it cannot be used.

Reproducible: Always

Comment 1

13 years ago
If you search Bugzilla for contentEditable you'll find two bugs covering this.  I'm marking this as a dup of the older one.

*** This bug has been marked as a duplicate of 97284 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.