Add building Sunbird from MOZILLA_1_8_BRANCH

VERIFIED FIXED in Sunbird 0.5

Status

Calendar
General
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Matthew (lilmatt) Willis, Assigned: Matthew (lilmatt) Willis)

Tracking

Trunk
Sunbird 0.5
Dependency tree / graph

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
We are currently building Lightning from trunk and MOZILLA_1_8_BRANCH. However, we only build Sunbird from trunk.

We'd like to have Sunbird also build from MOZILLA_1_8_BRANCH and upload nightlies.

The Linux tinderbox is pretty quick, so perhaps that box can handle the extra builds. The Mac (hilo) and Windows (solaria) boxes however, are already pretty slow, so something would need to be figured out there.

Thanks.
Blocks: 340951
The new tinderboxes 'Linux lt18-linux-tbox Dep Sb-Release' and 'MacOSX Darwin 7.9.0 hilo Dep Sb-Release' seem to work now and builds are available at [http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-mozilla1.8/].

The new tinderbox 'WINNT 5.2 solaria Dep Sb-Release' builds but fails during packaging and no builds are uploaded:

make: Leaving directory `/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/calendar/installer'
cp c:/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/dist/install/../*.zip c:/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/dist/install/2007-01-13-06-mozilla1.8/
Packaging failed
(Assignee)

Updated

12 years ago
Assignee: build → nobody
Component: Tinderbox Configuration → General
OS: Mac OS X → All
Product: mozilla.org → Calendar
QA Contact: ccooper → general
Hardware: Macintosh → All
Target Milestone: --- → Sunbird 0.5
Version: other → Trunk
(Assignee)

Comment 2

12 years ago
Created attachment 251402 [details] [diff] [review]
The MS VC8 redistributables should only be packaged on trunk

This makes tinderbox only attempt to package the MS VC8 redistributable bits on trunk builds.

This may not fix _all_ of solaria's troubles, but it sure is a prereq.
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #251402 - Flags: first-review?(jminta)

Comment 3

12 years ago
Comment on attachment 251402 [details] [diff] [review]
The MS VC8 redistributables should only be packaged on trunk

Why should our build scripts be particular to the mozilla tinderbox?  I feel like this just makes it more difficult for people building on their own.  Shouldn't the VC8 stuff be in some sort of a if (_MSC_VER >= 1400) block, rather than just picking a branch?
In my own 1.8 build the missing vc8 runtime files don't break packaging (just a warning) and from the tinderbox log I can see that the package is created too. The following copy command seems to fail as it aborts the packaging.
I wonder if the problem occurs slightly earlier in the log:

/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/build/cygwin-wrapper /cygdrive/c/moztools/bin/nsinstall ../../../dist/branding/branding.nsi ../../../dist/branding/license.txt ../../../dist/branding/wizHeader.bmp ../../../dist/branding/wizHeader2.bmp ../../../dist/branding/wizHeader3.bmp ../../../dist/branding/wizHeader4.bmp ../../../dist/branding/wizHeaderRTL.bmp ../../../dist/branding/wizWatermark.bmp ../../../dist/branding/wizWatermark2.bmp ../../../dist/branding/wizWatermark3.bmp ../../../dist/branding/wizWatermark4.bmp instgen
nsinstall: ..\..\..\dist\branding\branding.nsi: No such file or directory
nsinstall: ..\..\..\dist\branding\license.txt: No such file or directory
nsinstall: ..\..\..\dist\branding\wizHeader.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizHeader2.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizHeader3.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizHeader4.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizHeaderRTL.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizWatermark.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizWatermark2.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizWatermark3.bmp: No such file or directory
nsinstall: ..\..\..\dist\branding\wizWatermark4.bmp: No such file or directory
make[2]: *** [instgen/setup.exe] Error 3
make[2]: Leaving directory `/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/calendar/installer/windows'
make[1]: *** [installer] Error 2
make[1]: Leaving directory `/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/calendar/installer/windows'

I don't know if an error like this will be deferred, or even caught, but it might be what is turning the tbox orange.

Looks like Matt switched to --disable-installer in the mozconfig on 2006-12-19. At that time the build had been complaning:
configure: error: To build the installer makensis is required in your path. To build without the installer reconfigure using --disable-installer.
(http://tinderbox.mozilla.org/showlog.cgi?log=Sunbird-Mozilla1.8/1166562180.27578.gz&fulltext=1)
and NSIS didn't appear in the PATH envar. The build went orange after the change, with the same sort error as above. (I think it does this because there is no export done in calendar/installer/windows, so no branding files to use later).

NSIS does seem to be installed now (at least according to the PATH), so I suggest re-enabling the installer.
(Assignee)

Comment 6

12 years ago
Re-enabled.  Let's see what happens.
I wonder if the packaging error might be caused by using
  mk_add_options MOZ_PACKAGE_NSIS=1
  ac_add_options --disable-installer
at the same time in mozconfig. Setting MOZ_PACKAGE_NSIS to 0 might be worth testing too if the builds still fails with enabled installer.
Enabling the installer allows NSIS to work to some extent:

...
Compressing  optional\res\cmessage.txt
Compressing  nonlocalized\components\calendar.xpt
Compressing  optional\extensions\talkback@mozilla.org\components\qfaservices.xpt

Everything is Ok
/usr/bin/make instgen/7zSD.sfx
make[2]: Entering directory `/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/calendar/installer/windows'
/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/build/cygwin-wrapper upx --best -o instgen/7zSD.sfx /cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/other-licenses/7zstub/sunbird/7zSD.sfx
/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/build/cygwin-wrapper: line 75: exec: upx: not found
make[2]: *** [instgen/7zSD.sfx] Error 127
make[2]: Leaving directory `/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/calendar/installer/windows'
make[1]: *** [installer] Error 2
make[1]: Leaving directory `/cygdrive/c/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/calendar/installer/windows'
make: *** [installer] Error 2

So it needs UPX installed too, but that's all I can see missing from http://wiki.mozilla.org/ReferencePlatforms/Win32
Depends on: 367108
(Assignee)

Comment 9

12 years ago
Regardless, we should still remove the MSVC8 stuff from the packaging list, if only to make the logs more readable and remove the warning.

Joey: What's next for getting this patch reviewed?
(Assignee)

Comment 10

12 years ago
Comment on attachment 251402 [details] [diff] [review]
The MS VC8 redistributables should only be packaged on trunk

Moving reviews since jminta's crazy busy
Attachment #251402 - Flags: second-review?(mvl)
Attachment #251402 - Flags: first-review?(ssitter)
Attachment #251402 - Flags: first-review?(jminta)
Comment on attachment 251402 [details] [diff] [review]
The MS VC8 redistributables should only be packaged on trunk

r1=ssitter
Attachment #251402 - Flags: first-review?(ssitter) → first-review+
Comment 3 is still a valid question, without answer as far as I can see
(Assignee)

Comment 13

12 years ago
(In reply to comment #3)
The branch corresponds to a particular reference build environment (chosen by #build and whomever else... not us).  We could look into doing some MS compiler version ifdef, but that's not how Fx and Tb do this at the moment.

Comment on attachment 251402 [details] [diff] [review]
The MS VC8 redistributables should only be packaged on trunk

My issue is with other trying to build from branch. I think tinderbox builds will work with this, but other builds might not.
Anyway, if firefox does it like this, and nobody complained, I guess it will work for us too.

r2=mvl
Attachment #251402 - Flags: second-review?(mvl) → second-review+
(Assignee)

Comment 15

12 years ago
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.