Last Comment Bug 340515 - Support attribute-based repeats on table elements
: Support attribute-based repeats on table elements
Status: RESOLVED WONTFIX
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: ---
Assigned To: xforms
: Stephen Pride
Mentors:
http://www.w3.org/TR/xforms/
Depends on: 280368 358257
Blocks: 264329 322255
  Show dependency treegraph
 
Reported: 2006-06-06 07:10 PDT by Allan Beaufour
Modified: 2016-07-15 14:46 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Sample of XForms repeat-nodeset into table body (1.60 KB, text/html)
2006-10-18 09:14 PDT, Dan McCreary
no flags Details
testcase (1.48 KB, application/xhtml+xml)
2007-01-10 15:22 PST, aaronr
no flags Details

Description Allan Beaufour 2006-06-06 07:10:28 PDT
Bug 280368 added support for attribute based repeats in general, but it does not work for tables elements :(
Comment 1 Dan McCreary 2006-10-18 09:14:49 PDT
Created attachment 242647 [details]
Sample of XForms repeat-nodeset into table body

This example works in FormFaces.  If it runs correctly you should see a table with for people as in this: http://en.wikibooks.org/wiki/Image:XForms-table-repeat.jpg
Comment 2 alexander :surkov 2006-12-13 05:12:48 PST
The problem is because XBL bindings are not applied to table child elements (bug 83830). I don't mark this bug as dublicate of mentioned bug because we can rewrite attribute based repeat support view XTF for attributes (bug 358257).
Comment 3 aaronr 2007-01-10 15:22:38 PST
Created attachment 251128 [details]
testcase

same testcase, but I removed a formfaces-specific script-include line that was causing problems.
Comment 4 aaronr 2007-01-10 15:25:55 PST
looks better since bug 83830 was fixed.  At least now the data is showing up in the table.  But still not quite right.  Looks like the data is showing up all in one cell in one table row instead of separated out.
Comment 5 Jim Manico 2008-03-20 18:50:19 PDT
Any plan to fix this? 15 months of no activity, with respect, is disconcerting. Is there a suggested workaround?
Comment 6 alexander :surkov 2008-03-20 19:27:08 PDT
there is a bug 358257 preventing us to make progress on this.
Comment 7 David Bolter [:davidb] 2016-02-04 12:22:22 PST
RIP xforms

Note You need to log in before you can comment on or make changes to this bug.