Closed Bug 340657 Opened 14 years ago Closed 13 years ago

opener.focus() doesn't work if dom.disable_window_flip set to true

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 355482

People

(Reporter: crm, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

565 bytes, application/zip
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

on a main window execute the javascript:

mywin = window.open("www...", "wName", "height=500, width=600);
this bring up the window mywin on top.

in the mywin window click on the link:

<a href=javascript:window.opener.focus()>return</a>
the parent window receives the focus, but don't change his zOrder to the top position.

Reproducible: Always
Can you attach a testcase here? In general, focus() appears to raise the window on Windows XP, 2.0 nightly for me.
Attached file demofiles
the SwitchFocus.zip File contains two files who demonstrate the problem with window.opener.focus()
Thanks. So this doesn't work only if the "Raise or lower windows" option (dom.disable_window_flip) is set to true, which is default.
okay, this may end up invalid, but I'm not sure myself how disable_window_flip is supposed to interact with *opener*.focus().
Assignee: nobody → general
Component: General → DOM
Keywords: testcase
OS: Windows 2000 → Windows XP
Product: Firefox → Core
QA Contact: general → ian
Summary: window.opener.focus() don't bring the opener window on top position like ms ie → opener.focus() doesn't work if dom.disable_window_flip set to true
Version: unspecified → Trunk
Hello,

Please note that Firefox 1.5.x is no longer being developped, maintained, "is no longer supported with security and stability updates" since mid-july 2007. Please upgrade to Firefox 2
http://www.mozilla.com/en-US/firefox/all.html

Also, since there has been a similar bug for Firefox 2, I'm going to resolve this bug as a duplicate of bug 355482

Cheers, Gérard
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355482
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.