Sunbird fails if javascript.options.strict is set to true [in nsIModule::getClassObject]

RESOLVED DUPLICATE of bug 340019

Status

Calendar
General
--
major
RESOLVED DUPLICATE of bug 340019
12 years ago
12 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
Sunbird fails to work if javascript.options.strict is set to true [in nsIModule::getClassObject]

Steps to Reproduce:
1. Create a new profile and start Sunbird
   --> start is ok, views are displayed, everything looks fine
2. Quit Sunbird
3. Add user_pref("javascript.options.strict", true); to your prefs.js file
4. Start Sunbird

Actual Results:
Errors in JavaScript console (see below), views don't display properly, views can't be switched, it is not possible to create calendars, events, tasks, ...

After startup:

Error: [Exception... "'[object Object]' when calling method: [nsIModule::getClassObject]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: file:///Y:/tmp/sb-trunk-rel/dist/bin/components/calCompositeCalendar.js :: anonymous :: line 137"  data: no]

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///Y:/tmp/sb-trunk-rel/dist/bin/components/calCompositeCalendar.js :: anonymous :: line 137"  data: no]

Trying to switch views:

Error: gCalendarWindow has no properties
Source File: chrome://calendar/content/calendar.xul Line: 1

Start event dialog:

Error: [Exception... "'[object Object]' when calling method: [nsIModule::getClassObject]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: chrome://calendar/content/calendarUtils.js :: createToDo :: line 99"  data: no]

Error: uncaught exception: [Exception... "ComponentManager::CreateInstance returned failure code:"  nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calendarUtils.js :: createToDo :: line 99"  data: no]

Additional Information:
Setting javascript.options.strict back to false fixes everything.

Tested on my own Sunbird trunk build on Windows 2000 and with 2006-06-08-06 Sunbird nightly build on Linux.
(Reporter)

Updated

12 years ago
Depends on: 340019

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 340019 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
No longer depends on: 340019
No longer depends on: 340893
You need to log in before you can comment on or make changes to this bug.