Netscape 7.2 bookmarks with entity 39 instead of ' show correctly in NS7.2 but not in Seamonkey 1.0.2

RESOLVED DUPLICATE of bug 245758

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 245758
12 years ago
4 years ago

People

(Reporter: Steve Dunn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2

I had a number of bookmarks in Netscape 7.2 which, it turns out, had been saved by Netscape using ' (in case that doesn't show up properly, that's "ampersand number-sign 039 semicolon") in the names of Web sites such as Tom's Hardware Guide.  This particular bookmark file has been through several different versions of Netscape starting around 4.x and I can't be certain which one put the entity codes there.

In Netscape 7.2, and all other versions I used from 4.x through 7.2, they displayed as expected, both when dropping down the bookmarks and when editing bookmarks:  "Tom's Hardware Guide"

After upgrading to Seamonkey 1.0.2, they unexpectedly show up with the entity code visible instead of an apostrophe - again, both when dropping down the bookmarks and when editing bookmarks:  "Tom's Hardware Guide" (hope that shows up properly; in case it doesn't, it's "Tom[ampersand,number-sign,039,semicolon]s Hardware Guide")

Reproducible: Didn't try

Steps to Reproduce:
Sorry - I'm not going to repeatedly uninstall and reinstall Seamonkey and Netscape to try to duplicate the problem.
Actual Results:  
The numeric entity code is displayed

Expected Results:  
The character represented by the numeric entity code should be displayed
Whiteboard: DUPEME

Comment 1

12 years ago
You'll have to edit your Netscape 7.2 damaged bookmarks file, or create a new one, or delete the damage individual bookmarks and create new ones.

*** This bug has been marked as a duplicate of 245758 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.