improve usability of duplicate bug links

NEW
Unassigned

Status

()

--
enhancement
12 years ago
9 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
at the time of this bug's filing, bug 10000 was a duplicate of 6783.

steps:
1. load this bug
2. hover over "bug 10000"

expected results:
option 1 - tooltip:
text, "bug _10000_", hover over 10000 yields:
VERIFIED DUPLICATE (bug 6783) - Potential interface confusion re: HTMLDialog  windows
option 2 - extra link:
text: "bug _10000_ => _6783_"
hover over 10000 yields current message and hovering over 6783 yields title for bug 6783.

(exact ascii and text for => is negotiable).
"bug _10000_ [_6783_]" would be fine too, i'm not really picky. although ideally it should be trivial for me to double click and capture the right bug number w/o triggering a link so i can copy it and use it elsewhere.

bonus points: follow each element in the duplicate chain so that I don't have to file another bug when it turns out that a=>b=>c=>d and i'm unfortunate enough to look at a link to a.

"" denotes the range of text shown in a show_bug or equivalent view.
__ denotes a link range.

actual results:
tooltip:
VERIFIED DUPLICATE - Potential interface confusion re: HTMLDialog windows

problem: it's a big waste of my time to go click on a duplicate just to find out what it's a duplicate of. option 2 is prefered.
The version no of this bug should be updated to reflect that the need for this enhancement still applies to the current version of bugzilla (unless there's a completely different concept of version numbers here that I am not aware of).
OS: Windows XP → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.