clearInterval broken (Smoothwheel hangs)

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: ria.klaassen, Assigned: mrbkap)

Tracking

({hang, regression})

Trunk
x86
Windows XP
hang, regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

- Install the extension I'll attach by unzipping it and putting it in the extensions folder
- Go to a page with a reason to scroll and scroll down and up again
- Result: Firefox hangs, does not react anymore

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-06-12+16%3A00&maxdate=2006-06-12+20%3A00

Maybe bug 255942 has caused this?
Bug 255942 does not seem very likely to me.
Created attachment 225409 [details]
Smoothwheel extension
Keywords: hang, regression
It appears that window.clearInterval is not working, which is causing this hang.  I'll attach a testcase in a minute.
Created attachment 225415 [details]
testcase

You should see "broken" after 2 seconds if clearInterval fails to work.
Thank you! :)
Summary: Smoothwheel hangs trunk → clearInterval broken (Smoothwheel hangs)

Comment 5

13 years ago
Confirmed with Tinderbox Trunk of 13 June.

Windows XP-SP2

Comment 6

13 years ago
regression range 2006-06-12-05 - 2006-06-13-05, maybe bug 176182 ?
No, it is bug 255942, verified with Gavin's build. I meant in comment #0 that 243277 was not very likely, sorry, pasted wrongly. When you wide up the regression range a bit, also 255942 comes into view.
(Assignee)

Comment 8

13 years ago
Created attachment 225457 [details] [diff] [review]
Fix

This was a silly (type|think)-o.
Assignee: general → mrbkap
Status: NEW → ASSIGNED
Attachment #225457 - Flags: superreview?(bzbarsky)
Attachment #225457 - Flags: review?(mhammond)
Comment on attachment 225457 [details] [diff] [review]
Fix

r+sr=bzbarsky
Attachment #225457 - Flags: superreview?(bzbarsky)
Attachment #225457 - Flags: superreview+
Attachment #225457 - Flags: review?(mhammond)
Attachment #225457 - Flags: review+
(Assignee)

Comment 10

13 years ago
Fix checked into trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 11

13 years ago
*** Bug 341526 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
RCS file: /cvsroot/mozilla/js/tests/js1_5/Regress/regress-341360.js,v
done
Checking in regress-341360.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-341360.js,v  <--  regress-341360.js
initial revision: 1.1
done
Flags: in-testsuite+

Comment 13

13 years ago
verified fixed 1.9 windows/mac(ppc|tel)/linux 20060810
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.