Unicode character in text node value changes font family

RESOLVED DUPLICATE of bug 341054

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 341054
12 years ago
12 years ago

People

(Reporter: Tim De Pauw, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060612 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060612 Minefield/3.0a1

Using a Unicode character in text causes the entire element's value to be rendered in a different font, probably one that *does* provide that particular character.

Reproducible: Always

Actual Results:  
At the demo URL, the pager (Previous/Next Page) at the top should be in Verdana.

Expected Results:  
It is rendered in Arial. The same goes for similar elements, e.g. the Up/Down links with quotes.

This also demonstrates it:

data:text/html,<span style="font-family:verdana">Verdana&rarr;</span><span style="font-family:verdana">Verdana</span>

Probably related to bug 341054. Sorry if that's a dupe already.
Yes, it is a dupe. I can reproduce this on two computers.

*** This bug has been marked as a duplicate of 341054 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.