Last Comment Bug 341423 - .xpi Installation broken in Trunk (Regression)
: .xpi Installation broken in Trunk (Regression)
Status: VERIFIED DUPLICATE of bug 341362
: regression
Product: SeaMonkey
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: xpi-packages
: installer
Mentors:
Depends on: 341362
Blocks: dom-agnostic
  Show dependency treegraph
 
Reported: 2006-06-13 13:32 PDT by Tobias Fischer
Modified: 2008-07-31 02:13 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot from Install-Popup (5.75 KB, image/png)
2006-06-13 13:37 PDT, Tobias Fischer
no flags Details

Description Tobias Fischer 2006-06-13 13:32:45 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060613 Mnenhy/0.7.4.10001 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060613 Mnenhy/0.7.4.10001 SeaMonkey/1.5a

Using todays Nightly-Build: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060613 Mnenhy/0.7.4.10001 SeaMonkey/1.5a {Build ID: 2006061309}
*.xpi extensions won't install. The Software-Installation-Pop-Up-Window comes up, but there was no progress. 

xpi-install was o.k. in 2006061220, broken in 2006061309. I have missed the Builds between, so I can't cutdown the Regression-Range. 


Error Console throws:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://communicator/content/xpinstall/xpistatus.js :: onLoad :: line 131"  data: no]

Probably this was an Duplicate for Bug 341362 but I am not sure, because I don't know the differences between the Extension-Manager an install.js very much. 


Reproducible: Always

Steps to Reproduce:
1. Install or unpack SM-Trunk 2006061309
2. Try to install *.xpi, example at https://bugzilla.mozilla.org/attachment.cgi?id=225411
3. 

Actual Results:  
The Extension won't install, unable to close Install-Popup

Expected Results:  
The Extension should be install in SeaMonkey.
Comment 1 Tobias Fischer 2006-06-13 13:37:21 PDT
Created attachment 225464 [details]
Screenshot from Install-Popup
Comment 2 Mark Hammond [:markh] 2006-06-14 01:04:03 PDT
This looks like a dupe of 341362 - please try the patch there.
Comment 3 Tobias Fischer 2006-06-14 02:59:28 PDT
(In reply to comment #2)
> This looks like a dupe of 341362 - please try the patch there.
> 

Since bz has changed Bug 341362 to core and dom, I am quite sure that this one is an dupe. At mo I have no possibility to try the patch from there, I have wait for checkin and than I will try new Tinderbox-Builds. 

But I will mark this as Resolved=Duplicate for now, if this one will not be fixed by your patch it might be reopend. 

*** This bug has been marked as a duplicate of 341362 ***

Note You need to log in before you can comment on or make changes to this bug.