Message views for tags are broken

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: mnyromyr, Assigned: Bienvenu)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Thunderbird Mac/SeaMonkey Windows nightly of 2006-06-13

The message view dropdown still shows former labels, but respectively tagged messages aren't found/displayed in the thread pane (which, btw, still has a 'Labels' column). 

It seems as if the backend isn't reacting properly to tag/keyword filtering requests?

Furthermore, sorting by tags may need some discussion if messages have multiple tags: will that mean sorting by the alphabetically first tag or what?
(Reporter)

Updated

12 years ago
Depends on: 114656
(Assignee)

Comment 1

12 years ago
will look at this.
Assignee: nobody → bienvenu
(Assignee)

Comment 2

12 years ago
actually, new views based on tags work fine.  And the default label views (now tag views) work fine on messages that were labelled, not tagged. The problem seems to be that the old views are not upgraded to tag views, though I did change the search term loading code to upgrade label terms to tag terms.
(Assignee)

Comment 3

12 years ago
Created attachment 225745 [details] [diff] [review]
proposed fix

convert built-in views to do keyword tag searches, and fix backend search code to convert old labels to keywords in keyword tag searches.
Attachment #225745 - Flags: superreview?(sspitzer)
Comment on attachment 225745 [details] [diff] [review]
proposed fix

sr=sspitzer, acting super reviewer for mailnews while mscott is away
Attachment #225745 - Flags: superreview?(sspitzer) → superreview+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.