Inconsistently opening new tabs.

RESOLVED DUPLICATE of bug 339697

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 339697
12 years ago
12 years ago

People

(Reporter: tommyjb, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

I have found an inconsistency pertaining to the search bar, which seems to apply only when Google Search is selected thereon.

The user opens a new tab and then conducts a search using the search bar.  If this is done quickly (within about a second), another new tab is opened, automatically, and the search results are displayed in this new tab.  If this is not done so quickly, the current (blank) tab is used to display the results, as expected.

Reproducible: Always

Steps to Reproduce:
1. Open Alpha 3.
2. Ensure that Google Search is selected in the search bar.

The following steps must be performed quickly (within about a second) to reveal this bug.

3. Press Ctrl-T (new tab).
4. Press Ctrl-K (focus search bar).
5. Type something ("t", without the speech marks, works for me).
6. Press [enter].
Actual Results:  
A new tab is opened (thus two new tabs are opened overall), and the search results are displayed there.

Expected Results:  
The search results are displayed in the current tab.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
Already fixed for b1.

*** This bug has been marked as a duplicate of 339697 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.