Java apps on pogo.com hang FF when adblock installed

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: hacksoncode, Unassigned)

Tracking

({hang, qawanted})

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Bug 315841 purported to fix a bug where java applets would hang Firefox when AdBlock was installed. This still happens to me with 2006061804 on pogo.com. I was requested to open a new bug.

Steps to repro:

Install latest AdBlock Plus and latest JRE build 1.5.0_07-b03 (happens with older versions too). Go to Pogo.com and try to launch a game (e.g. Jigsaw Detective). The window will pop up, it will say it's loading the game, wait for it... it will eventually get to where it will change to a pale yellow window saying "Please wait..." (or the like). Nothing further will happen. FF is hung with 99% CPU usage and has to be killed via Task Manager's kill process.

Uninstalling AdBlock Plus fixes the problem.

Works in IE and in an IE Tab in FF.
Martijn, can you reproduce this, by any chance?
It seems I need to pay to become a member of http://pogo.com and be able to play any games.
I could subscribe for some trial period, which I could cancel, but I would still need to enter my credit card number. I highly prefer to not do that.
Reporter, maybe you could save the page in question and upload it to the bug? Maybe the bug would still be reproducable that way.

Comment 3

13 years ago
I have tried several games at pogo.com none of the ones I tried hung Firefox with adblock's default settings in a new profile. However I can't test Jigsaw Detective as it is one of the games you need to pay them a monthly fee to play. There is a test period but I don't want to give them my billing and credit card info.
As tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060619 Minefield/3.0a1 ID:2006061915 [cairo] and Java Plug-in 1.5.0_06.
(Reporter)

Comment 4

13 years ago
Sadly, I just registered a new account and tried it, and everything worked with Cribbage (a non-member game). 

Logged back on to my membership and tried Cribbage again and it hung.

So it only happens to members.

I think the long delay they introduce in order to show an advertisement to non-members might be masking this bug. The game loading sequence is quite different in the two cases.

For non-members, the sequence looks like: Advertisement, long delay, loading, everything works.

For member accounts, the sequence looks like: Starting Cribbage, switch to yellow background, Loading room... hung.

I don't know whether it would help, but I can send a free trial membership to someone (I have no idea whether entering a valid credit card is necessary in this case, as I've never been on the receiving side). That might be different than signing up for one directly, don't know...
(In reply to comment #4)
> I don't know whether it would help, but I can send a free trial membership to
> someone (I have no idea whether entering a valid credit card is necessary in
> this case, as I've never been on the receiving side). That might be different
> than signing up for one directly, don't know...

Ok, you could send a free trial membership to me, if you want to. That would be appreciated.
(Reporter)

Comment 6

13 years ago
Sent it off. Let me know if it doesn't arrive or there's some other problem.
Ok, thanks Ray.
I can reproduce it now. 
This regressed between 2005-12-02 and 2005-12-03:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-12-02+06&maxdate=2005-12-03+07&cvsroot=%2Fcvsroot
I guess a regression from bug 315841?
With the 2005-12-02 build, I get stuck with the "Starting Jigsaw Detective..." image. (so that is also a regression, from earlier)
With the 2005-12-03 build, I get to experience this bug.
(Reporter)

Comment 9

13 years ago
I would tend to be suspicious of the referents of the various "intermission...url" entries in there. Whether or not a advertising "intermission" is shown before the game is one of the few differences between the member and non-member experience. 
Hmm...  Martijn, if you set the base href on your copy of the page to the "right thing" (the pogo.com URI the page came from), does it reproduce the hang?

If so, could you try breaking in a debugger and seeing where we're spinning?

I'll try to get Java working after I get back and see whether I can reproduce, I guess...
(In reply to comment #10)
> If so, could you try breaking in a debugger and seeing where we're spinning?

I've tried to get Java working, but I get a build error:
http://wargers.org/mozilla/java_build_error.txt
I suspect that building with Java enabled, using mingw build environment doesn't work at all.

Updated

13 years ago
Blocks: 353557
Flags: blocking-firefox3?
Does this happen with Windows Seamonkey too?

Updated

13 years ago
No longer blocks: 353557
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: qawanted
Component: General → Plug-ins
Flags: blocking-firefox3+
Product: Firefox → Core
QA Contact: general → plugins
Flags: blocking1.9+
See also a discussion of bug 275783, comment 67 and further.
It turns out that current Java plugins for Firefox really suck and cause all kinds of bad things, which seem to be fixed in the upcoming Java plugin version.

Updated

12 years ago
Severity: major → critical
Keywords: hang
Are people still seeing this?
If this still happens reliably we should up the priority. Would be great if someone could test.
Priority: -- → P5
Unmarking this as blocker. If someone can still reproduce with the latest java version please let us know. Also let us know if it's a regression.
Flags: wanted1.9+
Flags: blocking1.9-
Flags: blocking1.9+
Priority: P5 → --

Comment 17

8 years ago
FWIW, posts on https://adblockplus.org/forum/viewtopic.php?t=5992 say this may be an ongoing issue between Pogo.com and any plugin that sets a content policy.
It works as expected on FF 19b1 and Latest Nightly (2013/01/10). This should be Resolved WFM.
Closing per comment 18, please re-open if you can reproduce this on a recent build.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.