Calendar show year value wrong 2006 is displayed as 106

RESOLVED DUPLICATE of bug 22964

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 22964
12 years ago
8 years ago

People

(Reporter: Siyad Ahmed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Any web page which has a calendar on it show year part wrongly. Year 2006 is displayed as 106 and dates and days of week are out of order because of that.

Reproducible: Always

Steps to Reproduce:
1.Go to any page which has calendar component on its form
2.click on the calendar to select a date.
3.view the problem.

Actual Results:  
if todays date is selected from calendar it comes like this - 19/6/106.

Expected Results:  
expected 19/6/2006.
Those sites should use getFullYear() instead.

*** This bug has been marked as a duplicate of 22964 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.