B F and M keys not available for cycling through Bookmarks sub-menus

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: denormalised, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.4) Gecko/20060607 Fedora/1.0.2-1.fc5 SeaMonkey/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.4) Gecko/20060607 Fedora/1.0.2-1.fc5 SeaMonkey/1.0.2

I believe this has already been fixed in Firefox.  I think the same should happen in SeaMonkey.

Bookmarks sub-menus beginning with B, F or M cannot be reached by respective key strokes, because such key strokes activate `Bookmark This Page', `File Bookmark' and `Manage Bookmarks'.  This is an inconvenient discrimination for keyboard users.

The correct behaviour (as implemented in Firefox) would be that these key strokes cycle through the sub-menus _and_ the B, F and M menu items.

Reproducible: Always

Steps to Reproduce:
1. Create Bookmarks folder `Music'
2. Press `Alt+B'
3. Press `M'
Actual Results:  
`Bookmark Manager' is activated; `Music' sub-menu is unreachable.

Expected Results:  
Step 3, repeated, should have cycled through `Manage Bookmarks', `Music' and any other sub-menus beginning with `M'.

This behaviour is also evident in Windows 2000.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 1

6 years ago
Can't reproduce on today nightly, closing
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.