Permission denied to set property XULElement.selectedIndex in handling focus() event

RESOLVED DUPLICATE of bug 236791

Status

Toolkit Graveyard
Error Console
RESOLVED DUPLICATE of bug 236791
12 years ago
2 years ago

People

(Reporter: Fernando Wendt, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

JavaScript Console / FireBug points error when using a script code to count string data lenght at one input type text, to make focus to next form field.

I have to count how many chars are present at the form field, and then, set the cursor to the next one. It works, but the following message reported is not clear what about is happening:

"[Exception... "'Permission denied to set property XULElement.selectedIndex' when calling method: [nsIAutoCompletePopup::selectedIndex]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: http://localhost/mysystem/jslib/forms.js :: FieldJump :: line 117" data: no]"

Reproducible: Always

Steps to Reproduce:
1. Create a XHTML form, with two input type text fields inside;
2. Create a JavaScript function, to count the string.length at the key events for field number one (i.e. onkeyup, onkeydown, onkeypress). Define some limit that make the jump (focus) to field number two;
3. Take a look at the JavaScript Console / FireBug

Actual Results:  
The console points a exception error message :

[Exception... "'Permission denied to set property XULElement.selectedIndex' when calling method: [nsIAutoCompletePopup::selectedIndex]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: http://localhost/mysystem/jslib/forms.js :: FieldJump:: line 117" data: no]

Expected Results:  
None exception neither error message at console.

At my JavaScript code, there´s a script tag that get the external "js" file (i.e. <script src="file.js"></script>). There´s no one inline code, function or something else at the main XHTML file.

The handler events are created dynamicly, using nested functions (like "AddEventListener(formfield, eventname, myfunction)". So, there´s none "onkeyup", "onclick" or something like it at the tags. The creator events function is called at body tag, "onload" event.

*** This bug has been marked as a duplicate of 236791 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.