Closed Bug 342165 Opened 14 years ago Closed 14 years ago

Style issues in new preferences dialog (gray lines in winstripe theme)

Categories

(Calendar :: Preferences, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

Attachments

(1 file)

Style issues in new preferences dialog (gray lines in winstripe theme)

The new preferences dialog landed yesterday shows some style issues on Windows. For example there is a light gray line below various items.

This is caused by the following css rule in calendar/base/themes/winstripe/preferences/preferences.css:

    caption {
        border-bottom: 1px solid #ececec;
        padding: 4px 4px 0px 0px !important;
    }

If I search lxr for this style rule it is found in the following pinstripe files too:
  /browser/themes/pinstripe/browser/preferences/preferences.css
  /mail/themes/pinstripe/mail/preferences/preferences.css

But this rule is not found in the corresponding winstripe files for Firefox or Thunderbird. Removing the rule from Sunbird css file improves situation. But some other elements still look odd (in some way).

Todo: 
Check winstripe preferences.css file for style rules that belong to pinstripe theme only or that are missing from winstripe theme.
Remove pinstripe rules from winstripe file. The rest (rules File Field Widget) looks ok / is identical to the rules found in Firefox or Thunderbird css file.
Assignee: base → ssitter
Status: NEW → ASSIGNED
Attachment #226343 - Flags: first-review?(jminta)
Attachment #226343 - Flags: first-review?(jminta) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

Thanks!

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
*** Bug 342424 has been marked as a duplicate of this bug. ***
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060630 Sunbird/0.3a2+.
Status: RESOLVED → VERIFIED
Component: Internal Components → Preferences
QA Contact: base → preferences
You need to log in before you can comment on or make changes to this bug.