search engines disappear/manage search engines doesnt work

VERIFIED DUPLICATE of bug 341981

Status

()

Firefox
Search
--
major
VERIFIED DUPLICATE of bug 341981
12 years ago
12 years ago

People

(Reporter: rana asim wajid, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060616 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060618 BonEcho/2.0a3

after updating from (Gecko/20060616 BonEcho/2.0a3) to any build from 18th onwards the search engines disappear from the search field and "manage search engines" when pressed opens up the "manage search engines list" box but the buttons do not respond and the only way to close it is by pressing "x".  

Reproducible: Always

Steps to Reproduce:
1.update to any build from 18th nightly onwards
2.
3.

Comment 1

12 years ago
A way to work around this is to delete storage.sdb from your profile. It's unclear though why an old (corrupted?) storage.sdb file would cause this.
I confirm this bug. If you open the browser manually, the engines are there.... if you open the browser via clicking an external link from a different application, the engines are gone and the search manager is broken.

Created attachment 226371 [details]
before the drop down

The Browser had been opened by a link in an external application
Created attachment 226373 [details]
After the drop down

The browser had been opened by a link in an external application
(Reporter)

Comment 5

12 years ago
(In reply to comment #1)
> A way to work around this is to delete storage.sdb from your profile. It's
> unclear though why an old (corrupted?) storage.sdb file would cause this.
> 

doesnt fix it for me
Here's what appears in the error console because of this:

Error: '[JavaScript Error: "engine has no properties" {file: "file:///C:/PROGRA~1/BONECH~1/components/nsSearchService.js" line: 2115}]' when calling method: [nsIBrowserSearchService::getVisibleEngines] = NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS
Source file: chrome://browser/content/search/search.xml
Line: 252

And:

Error: engine has no properties
Source file: file:///C:/PROGRA~1/BONECH~1/components/nsSearchService.js
Line: 2115
(Reporter)

Comment 7

12 years ago
> I confirm this bug. If you open the browser manually, the engines are there....
> if you open the browser via clicking an external link from a different
> application, the engines are gone and the search manager is broken.
> 

no in my case the search engines arent there no matter how i open firefox
When trying to manage searches, this is what appears:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://browser/content/search/engineManager.js :: engineManager_onOK :: line 46" data: no]
Source File: chrome://browser/content/search/engineManager.js
Line: 46

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://browser/content/search/engineManager.js :: engineManager_onCancel :: line 56" data: no]
Source File: chrome://browser/content/search/engineManager.js
Line: 56
(In reply to comment #7)
> > I confirm this bug. If you open the browser manually, the engines are there....
> > if you open the browser via clicking an external link from a different
> > application, the engines are gone and the search manager is broken.
> > 
> 
> no in my case the search engines arent there no matter how i open firefox
> 

Sometimes works this way for me also

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1a3) Gecko/20060620 BonEcho/2.0a3 ID:2006062004
(Reporter)

Comment 10

12 years ago
some feedback would be nice
You want resolution within five hours? You must be new here ;)

*** This bug has been marked as a duplicate of 341981 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
> You want resolution within five hours? You must be new here ;)
> 
> *** This bug has been marked as a duplicate of 341981 ***
> 

yes iam :p
Status: RESOLVED → VERIFIED

Comment 13

12 years ago
I Found a way to fix this just go into firefox safe mode then is gonna give you a choice of what to do then just chekc reset toolbar and continue and its fixed
You need to log in before you can comment on or make changes to this bug.