Lots of ###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr'

RESOLVED DUPLICATE of bug 340733

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 340733
12 years ago
9 years ago

People

(Reporter: Adam Guthrie, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
I'm seeing lots of these in a recent (2006-06-20) branch build.

Stack:
#0  NSGlue_Assertion (aStr=0xb2dd668 "QueryInterface needed", aExpr=0xb2dd680 "query_result.get() == mRawPtr", aFile=0xb305ef4 "../../../dist/include/xpcom/nsCOMPtr.h", aLine=594) at nsDebug.cpp:104#1  0x0b35b534 in nsCOMPtr<nsIDocumentObserver>::Assert_NoQueryNeeded () at /Users/aguthrie/moz/branch/mozilla/layout/mathml/base/src/nsMathMLChar.cpp:2429#2  0x0b1a75ac in nsXULDocument::ResumeWalk (this=0x184aa00) at ../../../../dist/include/xpcom/nsCOMPtr.h:714#3  0x0b1abd24 in nsXULDocument::CachedChromeStreamListener::OnStopRequest (this=0x641cb0, request=0xb2dd680, aContext=0xb305ef4, aStatus=594) at /Users/aguthrie/moz/branch/mozilla/content/xul/document/src/nsXULDocument.cpp:4561#4  0x0a14e244 in nsDocumentOpenInfo::OnStopRequest (this=0x671cb50, request=0x671ccd0, aCtxt=0x0, aStatus=0) at ../../dist/include/xpcom/nsCOMPtr.h:848#5  0x01013b18 in nsCachedChromeChannel::HandleLoadEvent (aEvent=0xb2dd668) at ../../dist/include/xpcom/nsCOMPtr.h:1149#6  0x2c064760 in PL_HandleEvent (self=0x671cd20) at /Users/aguthrie/moz/branch/mozilla/xpcom/threads/plevent.c:688#7  0x2c064644 in PL_ProcessPendingEvents (self=0x617c30) at /Users/aguthrie/moz/branch/mozilla/xpcom/threads/plevent.c:623#8  0x2c064b3c in _md_EventReceiverProc (info=0xb2dd668) at /Users/aguthrie/moz/branch/mozilla/xpcom/threads/plevent.c:1559#9  0x907dc4cc in __CFRunLoopDoSources0 ()#10 0x907db9fc in __CFRunLoopRun ()#11 0x907db47c in CFRunLoopRunSpecific ()#12 0x931d8980 in RunCurrentEventLoopInMode ()#13 0x932bce50 in GetNextEventMatchingMask ()#14 0x932bcd20 in WNEInternal ()#15 0x932bcc80 in WaitNextEvent ()#16 0x000109d0 in nsMacCommandLine::Initialize (this=0x4ed70, argc=@0x4ed60, argv=@0x4ed64) at /Users/aguthrie/moz/branch/mozilla/toolkit/xre/nsCommandLineServiceMac.cpp:158#17 0x000119fc in InitializeMacCommandLine (argc=@0xb35b534, argv=@0xb305ef4) at /Users/aguthrie/moz/branch/mozilla/toolkit/xre/nsCommandLineServiceMac.cpp:410#18 0x0000ff5c in XRE_main (argc=-1073746912, argv=0x37e8c, aAppData=0x0) at /Users/aguthrie/moz/branch/mozilla/toolkit/xre/nsAppRunner.cpp:2321#19 0x00008894 in main (argc=187553384, argv=0xb2dd680) at /Users/aguthrie/moz/branch/mozilla/browser/app/nsBrowserApp.cpp:61
I'm seeing this, and it is driving me nuts.

I'll look at the checkins and see what caused it.

thanks ispiked to confirming it wasn't just me and my tree.
Assignee: nobody → sspitzer
this bug is also on window.
Status: NEW → ASSIGNED
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
could it be related to the checkin for this?

Use iterators that deal with observers being removed to iterate the observers
array when notifying Bug 340733, r+sr+branch181=sicking
Yup, that's it, there's a patch in that bug, but it needs to be approved by the 1.8.1 people.

*** This bug has been marked as a duplicate of 340733 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.