"User Defined" dropdown in "Options>Content>Fonts&Colors>Advanced" is broken.

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
P3
normal
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: pal-moz, Assigned: florian)

Tracking

({regression})

Trunk
Firefox 3 beta3
x86
Windows XP
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

32.65 KB, image/jpeg
Details
(Reporter)

Description

12 years ago
Minefield [cairo]

Options>Content>Fonts&colors>Advanced
Choose "User Defined" and "OK"
again >Advanced. 

screenshot : http://img209.imageshack.us/img209/8492/fonts9ba.jpg

work fine 2006061904[cairo], so maybe regression 2006061904-2006062004
I bet this is related to Stuart's font changes.
Yes, it is caused by bug 341865.
Blocks: 341865
(Reporter)

Updated

12 years ago
Summary: dropdown in "Options>Content>Fonts&colors>Advanced" → "User Defined" dropdown in "Options>Content>Fonts&Colors>Advanced" is broken.
(Reporter)

Comment 3

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060721 Minefield/3.0a1 ID:2006072115 [cairo]

this seems to be fixed.
something is checked in ?
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060729 Minefield/3.0a1 ID:2006072904 [cairo]

sorry, my fault.
this still happenes.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3

Comment 5

11 years ago
Since this was asked on IRC:

Still sort of visible in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070526 Minefield/3.0a5pre

The dropdowns have no filled in text, but they function correctly.  That is, the height can contain one row of text, and I can open it and select a value.

JS console says "<preference> with id='' and name='' has unknown type ''."  (Console2 thinks there are 14 repeats.)

The bug is not exhibited when clicking Cancel in the Fonts dialog.  It appears that it has to do with setting the preference "font.language.group" to "x-user-def" while font.name.*.x-user-def are not set.

Updated

11 years ago
Target Milestone: Firefox 3 → Firefox 3 alpha6

Updated

11 years ago
Assignee: nobody → gavin.sharp
Status: REOPENED → NEW

Updated

11 years ago
Target Milestone: Firefox 3 alpha6 → Firefox 3 beta1
This is probably a dupe of bug 379886.
Depends on: 379886
(Reporter)

Comment 7

11 years ago
Created attachment 273179 [details]
Screen-shot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072005 Minefield/3.0a7pre ID:2007072005

not a dupe bug, I think.
see a screen shot.

Updated

11 years ago
Target Milestone: Firefox 3 M7 → Firefox 3 M8

Updated

10 years ago
Target Milestone: Firefox 3 M8 → Firefox 3 M9
(Reporter)

Comment 8

10 years ago
Created attachment 278346 [details]
screen shot

(In reply to comment #6)
> This is probably a dupe of bug 379886.
> 

379886 is fixed, but this bug is not fixed.
so not a dupe (Depends on/Blocks) bug.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007082615 Minefield/3.0a8pre
Attachment #273179 - Attachment is obsolete: true
moving out bugs that don't need to block b1
Target Milestone: Firefox 3 M9 → Firefox 3 M10

Updated

10 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11

Updated

10 years ago
Priority: -- → P3

Updated

10 years ago
Assignee: gavin.sharp → florian
(Assignee)

Comment 10

10 years ago
(In reply to comment #5)

> JS console says "<preference> with id='' and name='' has unknown type ''." 
> (Console2 thinks there are 14 repeats.)

This seems to be just noise and to have no visible effect. There is bug 391534 about this warning.
(Assignee)

Updated

10 years ago
Depends on: 408940
(Assignee)

Comment 11

10 years ago
So what's the bug here?

The error message mentioned in comment 5 is covered by bug 391534.

The fact that when you close the window and reopen it the visible values of the menulists are different is covered by bug 408940. When this bug will be fixed, the lists won't have any selected value for "User Defined" until you actually select something.

Should we add default values for all the x-user-def font prefs?
Sucks, but a bit of an edgecasey polish issue, as long as stuff still works this shouldn't block.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
(Reporter)

Comment 13

10 years ago
20080114_2053_firefox-3.0b3pre.en-US.win32.zip
bug 408940 was fixed.

but now, "Minimum font size" is blank,
http://img340.imageshack.us/img340/8426/a01ey2.jpg

and nothing is selected (all blank) in "User Defined".
http://img142.imageshack.us/img142/3995/a02hx1.jpg

intended or regression ?
(Assignee)

Comment 14

10 years ago
(In reply to comment #13)

> but now, "Minimum font size" is blank,
> http://img340.imageshack.us/img340/8426/a01ey2.jpg
> 
Hmm... we should probably select "None" when the pref is not set. I will probably look more into this.

> and nothing is selected (all blank) in "User Defined".
> http://img142.imageshack.us/img142/3995/a02hx1.jpg
> 
intended. Would it make sense to have default "user defined" values? I think it would not. And mconnor agreed with me on this when we discussed the status of this bug over IRC.
(Assignee)

Updated

10 years ago
Depends on: 414089
(Assignee)

Comment 15

10 years ago
(In reply to comment #14)
> (In reply to comment #13)
> 
> > but now, "Minimum font size" is blank,
> > http://img340.imageshack.us/img340/8426/a01ey2.jpg
> > 
> Hmm... we should probably select "None" when the pref is not set. I will
> probably look more into this.
> 

Filed bug 414089 to cover this issue.

Everything else works for me as expected.
Status: NEW → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.