Last Comment Bug 342265 - "Apple Symbols" font is ignored.
: "Apple Symbols" font is ignored.
Status: RESOLVED WORKSFORME
:
Product: Core Graveyard
Classification: Graveyard
Component: GFX: Mac (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Josh Aas
:
Mentors:
http://hsivonen.iki.fi/test/u2619.html
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 02:24 PDT by distler
Modified: 2009-01-22 10:17 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description distler 2006-06-21 02:24:18 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060619 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060619 SeaMonkey/1.5a

The "Apple Symbols" font is installed on MacOSX 10.3 and later.

It shows up in the Font Menu in Firefox and Camino (but not SeaMonkey -- a separate bug?).

Still, glyphs present in that font are not rendered (treated as missing).

Look at ⋆ (U+22C6) or ☙ (U+2619), to pick two examples.

Reproducible: Always

Steps to Reproduce:
1. View a page containing Unicode code-points supported by "Apple Symbols", but not by other installed fonts.

Actual Results:  
Rendered as missing (?)

Expected Results:  
Should have been rendered using glyphs from "Apple Symbols"
Comment 1 Henri Sivonen (:hsivonen) 2006-06-21 02:50:34 PDT
Confirmed on trunk.
Comment 2 Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-11-27 21:59:04 PST
This works in a 1.8 branch (!) Camino, and in a cairo-cocoa Camino, so I assume it's fixed in a cairo-cocoa Minefield, too.
Comment 3 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-02-17 00:44:52 PST
Since Henri's testcase works in a branch Camino, I presume it was Cocoa widgets that fixed this for everyone else, but closing WFM since I'm not sure and don't feel like digging around for an exact build.

WFM in Gran Paradiso Alpha 2, of course.

Note You need to log in before you can comment on or make changes to this bug.