Displaying linebreak after the table with display:inline-table css propetry set

RESOLVED DUPLICATE of bug 18217

Status

RESOLVED DUPLICATE of bug 18217
13 years ago
13 years ago

People

(Reporter: denisjuk, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux; ru, pl, en_US) KHTML/3.5.3 (like Gecko) (Debian)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060417

I defined a css style element table {display:inline-table}. However tables are displayed with a linebreak after. Here is an exmaple (XHTML/CSS cheked):
===================================================================
<?xml version="1.0" encoding="utf-8" standalone="no"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><head>
<style type="text/css">
body {text-align:center}
table {display:inline-table}
img {margin:1em;padding:0em;border-style:solid;border-width:1em;border-color:rgb(250,240,230)}
</style>
<title>
2006-06-22-Ustron
</title></head><body>
<hr />
<table>
<tr> <td>
<a href='IMG_1319.JPG' ><img height='75' src='_IMG_1319.JPG' alt='IMG_1319.JPG' 
title='IMG_1319.JPG (1416600 bytes)' /></a>
</td></tr><tr>
<th>
IMG_1319.JPG<br />(1416600 bytes)</th></tr></table>
<table>
<tr> <td>
<a href='IMG_1321.JPG' ><img height='75' src='_IMG_1321.JPG' alt='IMG_1321.JPG' 
title='IMG_1321.JPG (1217626 bytes)' /></a>
</td></tr><tr>
<th>
IMG_1321.JPG<br />(1217626 bytes)</th></tr></table>
<hr />
</body></html>
==================================================================================


Reproducible: Always

Steps to Reproduce:
1. Save above example as a file and view it by Mozilla or Firefox


Actual Results:  
You will see tables arranged in a column (there will be a linebreak after each table)

Expected Results:  
Instead, tables should be arranged in a (centered) line, without any linebreaks after each table, since tables have 'display:inline-table' css property

If you will replace 'inline-table' by 'inline' tables will be displayed in correct way. However someone says that table cannot be 'inline' and should be 'inline-table'. Moreover, in case of 'inline' Konqueror fails. Since I use Konqueror, my wife prefers Firefox, I decided to report a bug to both:-)

Comment 1

13 years ago
dupe of "display: inline-table not implemented"

*** This bug has been marked as a duplicate of 18217 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.