Closed Bug 342616 Opened 17 years ago Closed 17 years ago

Firefox doesn't overwrite existing files on download when told to do so

Categories

(Toolkit :: Downloads API, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 341771

People

(Reporter: dennisml, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060621 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060621 Minefield/3.0a1

When I download a file and a file with the same name already exists in the target folder Firefox ask me if it should overwrite that file however replying to this with "yes" creates a new file instead.

Reproducible: Always

Steps to Reproduce:
1. Download a file like e.g. "firefox-3.0a1.en-US.linux-i686.tar.bz2"
2. Download the same file to the same location
3. Respond to the dialog that asks if Firefox should overwrite the file with "yes"

Actual Results:  
Firefox downloads the file with "(2)" inserted before the file suffix instead ("firefox-3.0a1.en-US.linux-i686(2).tar.bz2").

Expected Results:  
Firefox should overwrite the old file.
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 341771 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.