Last Comment Bug 342624 - Change phrasing of "Advanced" button tip in Appearance/Fonts
: Change phrasing of "Advanced" button tip in Appearance/Fonts
Status: VERIFIED FIXED
: verified1.8.1
Product: Camino Graveyard
Classification: Graveyard
Component: Preferences (show other bugs)
: unspecified
: PowerPC Mac OS X
-- trivial (vote)
: Camino1.5
Assigned To: froodian (Ian Leue)
:
:
Mentors:
Depends on:
Blocks: 325880
  Show dependency treegraph
 
Reported: 2006-06-24 09:13 PDT by Paul Borokhov (lensovet)
Modified: 2006-08-25 15:12 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
New Appearance.nib (20.61 KB, application/zip)
2006-07-02 16:50 PDT, froodian (Ian Leue)
no flags Details
Screenshot of the colors & links tab (54.65 KB, image/png)
2006-07-02 16:50 PDT, froodian (Ian Leue)
no flags Details
Screenshot of links tab (65.70 KB, image/png)
2006-07-02 16:51 PDT, froodian (Ian Leue)
no flags Details
Screenshot of advanced sheet (76.81 KB, image/png)
2006-07-02 16:51 PDT, froodian (Ian Leue)
no flags Details
Minor IRC tweaks (20.61 KB, application/zip)
2006-07-02 22:58 PDT, froodian (Ian Leue)
no flags Details
Sets min width/height (20.58 KB, application/zip)
2006-07-02 23:02 PDT, froodian (Ian Leue)
no flags Details
Not b0rken (20.60 KB, application/zip)
2006-07-02 23:41 PDT, froodian (Ian Leue)
no flags Details
Makes dropdown menu longer (20.62 KB, application/zip)
2006-07-03 00:07 PDT, froodian (Ian Leue)
alqahira: review+
mikepinkerton: superreview+
Details
Screenshot of Colors & Links side (57.37 KB, image/png)
2006-07-05 19:40 PDT, froodian (Ian Leue)
no flags Details
Screenshot of Links side (68.19 KB, image/png)
2006-07-05 19:40 PDT, froodian (Ian Leue)
no flags Details
Screenshot of advanced sheet (34.84 KB, image/png)
2006-07-05 19:40 PDT, froodian (Ian Leue)
no flags Details

Description User image Paul Borokhov (lensovet) 2006-06-24 09:13:06 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060614 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060614 Camino/1.0+

As part of the checkin for bug 277278, we introduced a new "Advanced" button "tip". Currently it reads « In Advanced you can set the minimum font size or other font types for this region. »
I propose we change it to « To set the minimum font size and other font types for this region, click Advanced... ». I'm not really crazy about the current version, in part because it uses the word "you", which I think is a little weird for a UI. Also, it says "or", though I don't get why - you can change Both the font size And the font types in the sheet. There's also a comma missing after Advanced. The new version would also go above the button, rather than below it.

Reproducible: Always
Comment 1 User image froodian (Ian Leue) 2006-06-24 10:43:05 PDT
We use "you" all throughout the prefpanes, so I don't think that's bad, but I do agree that the text could be less awkward.  Perhaps just 

"Set the minimum font size and other font types for this region."  

This would keep parity with the tip text for webfeatures.prefpane's "Add sites that should be allowed to show pop-up windows to a list."

The text should still be below the button though, since this is what we do with all our other tip texts.  By the way, bug 277278 didn't introduce the tip, it just capitalized the word "Advanced."
Comment 2 User image Paul Borokhov (lensovet) 2006-06-24 11:21:30 PDT
ah, ok :). I see the reference in webfeatures, and then this sounds OK. I'm not exceptionally crazy about it just saying "Set...", but consistency works, and I don't like the idea of saying "click this" as well. and compromise is good, so I say your version works.

p.s. as for you using "you" elsewhere, we only use it in Keychain access, and that wording needs to get changed too. Have it say «Edit your keychain items» (or maybe, Edit your keychain items with the Keychain Access app). And then make the "some websites won't let you save..." go on a separate line.
Comment 3 User image froodian (Ian Leue) 2006-06-29 04:21:50 PDT
When this is done we should be sure to resize the window correctly (595px) and make "Page Colors" consistent with "Link appearance"
Comment 4 User image froodian (Ian Leue) 2006-07-02 16:50:03 PDT
Created attachment 227914 [details]
New Appearance.nib
Comment 5 User image froodian (Ian Leue) 2006-07-02 16:50:33 PDT
Created attachment 227915 [details]
Screenshot of the colors & links tab
Comment 6 User image froodian (Ian Leue) 2006-07-02 16:51:02 PDT
Created attachment 227916 [details]
Screenshot of links tab
Comment 7 User image froodian (Ian Leue) 2006-07-02 16:51:22 PDT
Created attachment 227917 [details]
Screenshot of advanced sheet
Comment 8 User image froodian (Ian Leue) 2006-07-02 16:57:02 PDT
One question:  How should we do the px at the top of the prefpane?  I just left it the way it was, but do we want it 20px from the top of the "this is inside the tabview" area, or 20px from the top of the tabs? (sorry for the bugspam)
Comment 9 User image froodian (Ian Leue) 2006-07-02 22:58:12 PDT
Created attachment 227931 [details]
Minor IRC tweaks

This is more or less like the screenshots.  Just a couple px here and there.
Comment 10 User image froodian (Ian Leue) 2006-07-02 23:02:56 PDT
Created attachment 227933 [details]
Sets min width/height
Comment 11 User image froodian (Ian Leue) 2006-07-02 23:41:09 PDT
Created attachment 227936 [details]
Not b0rken

Sorry, that last nib was a dud (saved showing the wrong tab).
Comment 12 User image froodian (Ian Leue) 2006-07-03 00:07:09 PDT
Created attachment 227938 [details]
Makes dropdown menu longer

Hi reed.
Comment 13 User image Reed Loden [:reed] (use needinfo?) 2006-07-03 00:12:36 PDT
(In reply to comment #12)
> Hi reed.

Hi! How are you doing? :)
Comment 14 User image Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-07-03 00:18:32 PDT
Comment on attachment 227938 [details]
Makes dropdown menu longer

r=me

Hopefully this is the end of this party :-)
Comment 15 User image Paul Borokhov (lensovet) 2006-07-03 22:15:10 PDT
(In reply to comment #8)
> One question:  How should we do the px at the top of the prefpane?  I just left
> it the way it was, but do we want it 20px from the top of the "this is inside
> the tabview" area, or 20px from the top of the tabs? (sorry for the bugspam)
> 

actually, 10px from the bottom of the tabs. see http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/art/ct_tabpaneinset.gif and http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGControls/chapter_18_section_7.html#//apple_ref/doc/uid/TP30000359-DontLinkElementID_524
Comment 16 User image froodian (Ian Leue) 2006-07-03 23:36:41 PDT
I was referring to the space between the tabs and the top of the window, not the tabs and the top of the inset, but thanks.  It's dealt with (per IRC). :)
Comment 17 User image Mike Pinkerton (not reading bugmail) 2006-07-05 07:04:18 PDT
what are we fixing here? i'm so confused.
Comment 18 User image froodian (Ian Leue) 2006-07-05 07:08:46 PDT
We're:

- Changing "In Advanced you can set the minimum font size or
other font types for this region." to "Set the minimum font size and other font types for this region."
- Correcting margins and spacing to match all the other prefpanes' new standard
- Making "Link appearance" "Link Appearance" to match "Page Colors"

In other words, just cosmetic polish as part of the prefpane cleanup.
Comment 19 User image froodian (Ian Leue) 2006-07-05 19:40:15 PDT
Created attachment 228247 [details]
Screenshot of Colors & Links side

I realized that the screenshots included are a few revisions out of date (even though there have only been minor changes since then).  Uploading screenshots of the final versions for sr-ing pleasure. ;)
Comment 20 User image froodian (Ian Leue) 2006-07-05 19:40:34 PDT
Created attachment 228248 [details]
Screenshot of Links side
Comment 21 User image froodian (Ian Leue) 2006-07-05 19:40:53 PDT
Created attachment 228249 [details]
Screenshot of advanced sheet
Comment 22 User image Mike Pinkerton (not reading bugmail) 2006-07-21 06:27:00 PDT
Comment on attachment 227938 [details]
Makes dropdown menu longer

rs=pink
Comment 23 User image Nick Kreeger 2006-07-21 17:52:11 PDT
Fixed trunk and branch.

Note You need to log in before you can comment on or make changes to this bug.