Closed Bug 342734 Opened 14 years ago Closed 14 years ago

Repetitive script error

Categories

(Firefox :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 335058

People

(Reporter: delrica, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

While using Firefox to check email (www.gmail.com), Firefox repetitively displays the following window:

WARNING: Unresponsive Script

A script on this page may be busy, or it may have stopped responding. You can stop the script now or you can continue to see if the script will complete.

Button 1: Stop Script, Button 2: Continue

Reproducible: Always

Steps to Reproduce:
1. open firefox
2. go to www.gmail.com and login to check your email
3. error pops up while using gmail (be it for navigation, reading your email, or just sitting on the gmail site in general)

Actual Results:  
The aforementioned error occurs every time I use Firefox to check my email.  Sometimes the script just keeps rerunning and when you come back to your computer, you'll have several occurrances of the error on your screen (you won't know it until you close one window, only to find there's another right behind it as they stack directly on top of each other).

Expected Results:  
I don't know what the software should have done as I don't know the script that's causing the problem.  But it either halts operation of Firefox or slows down performance of it and any other open application when the error is occurring or when it hasn't been cleared.

I really like Firefox and have had no problems operating it ever.  This has gotten so bad that I've actually had to go back to Internet Explorer to check email and move around on the web.
You could increase the value of the pref dom.max_script_run_time , see http://kb.mozillazine.org/About:config


*** This bug has been marked as a duplicate of 335058 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.