Allow drag & drop in search engine drop-down list

RESOLVED WONTFIX

Status

()

Firefox
Search
--
enhancement
RESOLVED WONTFIX
12 years ago
7 years ago

People

(Reporter: chaitanyaaa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

One should be able to sort search engines in the drop-down list using drag & drop.
IMHO, this is more intuitive and convenient. The user shouldn't unnecessarily be forced to go into a separate interface (the manager window) to make a small change in the interface in question (rearranging the engines).
Besides this functionality already exists in the bookmarks menu.

Reproducible: Always

Steps to Reproduce:
1.Click on the dropmarker in the search field to bring up the search engines list.
2.Try to drag an engine to another position within the list.

Actual Results:  
Nothing happens

Expected Results:  
The search engine should be moved to the new position.

*** This bug has been marked as a duplicate of 335086 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Oh, in the drop-down. I don't know that that's really desirable...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago
Citing the Windows HIG from http://msdn.microsoft.com/library/en-us/dnwue/html/ch08b.asp

> If the user presses the mouse button, then moves the pointer off the menu and releases the mouse button, the menu is also closed. However, if the user moves the pointer back onto the menu before releasing the mouse button, the pointer tracking resumes and the user can still select a menu item.

Introducing drag&drop for menu items - while convenient for a minority of advanced users - will break HIG compliance for IMHO not that beneficial reasons. Suggesting WONTFIX.

Comment 4

12 years ago
This is a totally valid point, and what many users expect in terms of quickly organising items in the interface, in that same interface itself.  Forcing users into a seperate box is not good at all, its in no way providing choice.  The search engine manager is good and should remain (perhaps with more options and powers over time) although it should be in the addons manager, as it like web plugins are addons.  As per Bookmarks, tabs and more, users should at least be able to drag and drop search engines to re-order them, and be able to delete them without having to go into another window interface everytime for such menial small tasks.  

Some say right click context menu and re-ordering should not be functional in bookmarks for similar reasons you state, but drag and drop re-ordering, and a context menu for basic things like delete, is provided.  Why, because its what users expect and find most easy, effecting the interface within the same interface, not ONLY a seperate layer of UI.  

That takes away choice, clutters, and over complicates simple tasks like re-ordering and deleting.  There should not be a mixture of drag and drop, options for some items like bookmarks, tabs so users expect to be able to effect the UI within the same one, but then contradict that by it not being true in other areas, such as the search engine manager.  Drag and drop re-ordering, deleteing and more like elsewhere in the browser, should ALSO be a capability within the same UI.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
WONTFIX, given comment 2.
Status: NEW → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → WONTFIX

Updated

9 years ago
Duplicate of this bug: 472525

Comment 7

9 years ago
Should be noted that items in the Start menu are draggable, so Microsoft apparently recognizes exceptions should be made in certain circumstances.

Comment 8

7 years ago
Also note that the new "Firefox" menu takes the guidelines and mashes them to a pulp. Again, there's nothing wrong with an exception here and there.

I believe this feature would be genuinely useful. If there's worry about users trying to drag off the menu to not perform an action, the background can just be made the same color as the Firefox button to indicate that it isn't a standard menu...
You need to log in before you can comment on or make changes to this bug.