Last Comment Bug 342961 - Get a CSS error on displaying any SVG
: Get a CSS error on displaying any SVG
Status: RESOLVED FIXED
: fixed1.8.0.7, fixed1.8.1
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Robert Longson
: Hixie (not reading bugmail)
Mentors:
Depends on: 331432
Blocks: 331883
  Show dependency treegraph
 
Reported: 2006-06-28 04:08 PDT by Robert Longson
Modified: 2006-08-23 07:59 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (834 bytes, patch)
2006-06-28 04:15 PDT, Robert Longson
bzbarsky: review+
bzbarsky: superreview+
darin.moz: approval1.8.1+
Details | Diff | Review
branch patch (1.22 KB, patch)
2006-06-29 14:23 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
dveditz: approval1.8.0.7+
Details | Diff | Review

Description Robert Longson 2006-06-28 04:08:01 PDT
CSS Error (resource://gre/res/svg.css :72.30): Unknown pseudo-class or
pseudo-element '-moz-svg-foreign-content'.  Ruleset ignored due to bad
selector.
Comment 1 Robert Longson 2006-06-28 04:15:13 PDT
Created attachment 227395 [details] [diff] [review]
patch

The only callers to EnsureCatalogStyleSheet are svg\content\src\nsSVGElementFactory.cpp and xml\document\src\nsXMLContentSink.cpp in both cases they pass a fixed stylesheet.
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2006-06-28 08:58:19 PDT
Comment on attachment 227395 [details] [diff] [review]
patch

Looks great.  r+sr=bzbarsky
Comment 3 Robert Longson 2006-06-28 09:22:10 PDT
Checked in.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2006-06-28 14:43:11 PDT
Comment on attachment 227395 [details] [diff] [review]
patch

We should take this on branches. This specific bug does not exist on branches (because they don't support foreignobject) but the risk is minimal and the patch belongs with the patch for bug 331883, which has landed on branches.
Comment 5 Darin Fisher 2006-06-28 20:49:14 PDT
Comment on attachment 227395 [details] [diff] [review]
patch

a=darin on behalf of drivers
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2006-06-29 14:22:30 PDT
checked into 1.8.1
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2006-06-29 14:23:23 PDT
Created attachment 227606 [details] [diff] [review]
branch patch

This is the patch that should go into 1.8.0.6
Comment 8 Daniel Veditz [:dveditz] 2006-08-15 15:29:22 PDT
Comment on attachment 227606 [details] [diff] [review]
branch patch

approved for 1.8.0 branch, a=dveditz for drivers
Comment 9 Daniel Veditz [:dveditz] 2006-08-23 07:59:07 PDT
Fix checked into 1.8.0 branch

Note You need to log in before you can comment on or make changes to this bug.