a location bar search with the sidebar closed crashes

VERIFIED FIXED in M15

Status

SeaMonkey
Search
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Claudius Gayle, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description: 

  Search fails smoketesting today. If you click the sidebar closed and do a location bar search (type some text- click search) the 
browser will crash.

Steps to Reproduce: 

1) Launch browser. Click to close the sidebar.

2) type some text in the location field.

3) Click the search button.



Actual Results: 

	The sidebar pops open and then the browser crashes.

Expected Results: 

	No crash.

Build Date & Platform Bug Found: 

	WinNT 2000040209 build. repro'd on 2000040309 Linux build.

Additional Builds and Platforms Tested On: 

	On the Mac build clicking search had no effect whatsoever.

Additional Information:

	I'm having trouble reproducing this again. Evidently the initial conditions matter, but this was repro'd on 3 different 
machines and 2 different platforms - the stack trace is below.

 Call Stack:    (Signature = nsDSWebProgressListener::OnStatusChange 141cec2a) 
     
     nsDSWebProgressListener::OnStatusChange 
                                                                     [d:\builds\seamonkey\mozilla\docshell\base\nsDSWebProgressListener.cpp, line 
95]
     
     nsDocLoaderImpl::FireOnEndDocumentLoad 
                                                                     [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 623]
     
     nsDocLoaderImpl::DocLoaderIsEmpty 
                                                                     [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 514]
     
     nsDocLoaderImpl::OnStopRequest 
                                                                     [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 458]
     
     nsLoadGroup::RemoveChannel 
                                                                     [d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 550]
     
     nsHTTPChannel::ResponseCompleted 
                                                                     [d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, 
line 1502]
     
     nsHTTPServerListener::OnStopRequest 
                                                                     [d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\
nsHTTPResponseListener.cpp, line 538]
     
     nsOnStopRequestEvent::HandleEvent 
                                                                     [d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
286]
     
     nsStreamListenerEvent::HandlePLEvent 
                                                                     [d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
98]
     
     PL_HandleEvent 
                                                                     [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 564]
     
     PL_ProcessPendingEvents 
                                                                     [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 527]
     
     _md_EventReceiverProc 
                                                                     [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1020]
     
     USER32.dll + 0x1268 (0x77e71268)

Comment 1

19 years ago
I'm out all week.
Can YOU take a look at this.

thx
Assignee: matt → rjc

Comment 2

19 years ago
Just guessing:  Docshell problem?  Travis?
Assignee: rjc → travis

Comment 3

19 years ago
Flipping to mscott.  He has a patch.  This is actually the same problem that is 
causing 34350.
Assignee: travis → mscott
(Assignee)

Comment 4

19 years ago
I have a fix for this in my tree as soon as the real tree opens =).
Status: NEW → ASSIGNED
Target Milestone: --- → M15
(Assignee)

Comment 5

19 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
*** Bug 34387 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

19 years ago
VERIFIED with 2000040509 builds
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.