Session restore clobbers my window position on restore

VERIFIED FIXED in Firefox 3.1a2

Status

()

VERIFIED FIXED
13 years ago
7 years ago

People

(Reporter: ispiked, Assigned: zeniko)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 3.1a2
x86
Linux
Points:
---
Bug Flags:
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060626 Minefield/3.0a1

Steps to reproduce:
1. Set browser.sessionstore.resume_session to true.
2. Make sure the window /isn't/ maximized, or in the top left of the screen.
3. Restart Firefox.

Results:
The browser window is positioned in the top left corner of the screen.

Expected results:
The browser window's position is restored to where it was previously.

This works when I don't use session restore, so it's gotta be something session restore does.
(Reporter)

Comment 1

13 years ago
This also happens on branch and when just resuming the session if it crashed.
(Reporter)

Comment 2

12 years ago
So, does session store explicitly store the window position (doesn't look like it after a glance at the code) or just expect localstore.rdf to take care of this? Or maybe session store is overriding what localstore.rdf says...
(Assignee)

Comment 3

12 years ago
(In reply to comment #2)
SessionStore explicitly saves the windows' positions (in _updateWindowFeatures) and relies on localstore.rdf only for the very first window to be restored (otherwise restoreWindowFeatures should move the window back where it was).
(Assignee)

Comment 4

12 years ago
*** Bug 364389 has been marked as a duplicate of this bug. ***
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
(Assignee)

Comment 5

11 years ago
Created attachment 331808 [details] [diff] [review]
never use the window dimensions from localstore.rdf
Attachment #331808 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #331808 - Flags: review? → review?(dietrich)
Comment on attachment 331808 [details] [diff] [review]
never use the window dimensions from localstore.rdf

r=mano
Attachment #331808 - Flags: review?(dietrich) → review+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Assignee: nobody → zeniko
http://hg.mozilla.org/index.cgi/mozilla-central/rev/6c8bb2e4fb41
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a2
Verified with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090617 Minefield/3.6a1pre ID:20090617031528
Status: RESOLVED → VERIFIED
Flags: in-litmus?
in-litmus-
There are multiple tests in litmus that include window size/position in their Expected Results.  A specific test case is not needed IMO.
Flags: in-litmus? → in-litmus-

Updated

7 years ago
Depends on: 680001
(In reply to Dão Gottwald [:dao] from comment #7)
> http://hg.mozilla.org/index.cgi/mozilla-central/rev/6c8bb2e4fb41

This appears to have caused a regression (see bug 680001)
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #10)
> (In reply to Dão Gottwald [:dao] from comment #7)
> > http://hg.mozilla.org/index.cgi/mozilla-central/rev/6c8bb2e4fb41
> 
> This appears to have caused a regression (see bug 680001)

Technically yes, but meh. That should be solved differently.
You need to log in before you can comment on or make changes to this bug.