GUI should run in a separate thread for each tab

RESOLVED DUPLICATE of bug 40848

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 40848
13 years ago
12 years ago

People

(Reporter: gideon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Currently, all GUI activity takes place in the same thread. This means that, for example, if a page loading in the background is taking a long time to layout or has a long-running script, the entire browser freezes. This is particularly relevant for extensions which cause every large page to display slowly.

Reproducible: Always

Steps to Reproduce:
1. Use greasemonkey to inject a slow script into every page (yes, I have a very good reason for doing this)
2. Load some pages in background tabs
3. Make and drink a cup of coffee while waiting for the browser to become responsive


Expected Results:  
Each tab should layout its page and execute scripts in its own thread

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 40848
You need to log in before you can comment on or make changes to this bug.