Filters disappear from message filters dialog after editing filter

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: infoman1985, Assigned: ajschult784)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060702 /


After changing any filters in filters dialog all filters disappear. After closing and reopening dialog filters are visible again, modifications applied successful

Reproducible: Always

Steps to Reproduce:
1. Open MailNews window
2. Open Message Filters dialog
3. Try to edit any filter

Actual Results:  
All filters disappear from dialog

Expected Results:  
Filters list updates nd shows new filters' state

From about:buildconfig
gcc version 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)

Compiler flags
gcc     -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-pedantic -pthread -pipe
c++     -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe

Configure arguments
--enable-optimize --disable-debug --enable-default-toolkit=cairo-gtk2
--enable-glitz --enable-xft --disable-static --enable-shared --disable-tests
--enable-canvas --enable-svg --enable-strip --enable-elf-dynstr-gc
--enable-application=suite --enable-static-mail

MOZ_XUL_APP=1
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
(Assignee)

Comment 1

13 years ago
Error: gMessengerBundle has no properties
Source File: chrome://messenger/content/msgFolderPickerOverlay.js
Line: 118

This is bustage from bug 182274...
Blocks: 182274
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 2

13 years ago
Created attachment 227919 [details] [diff] [review]
use the id
Assignee: mail → ajschult
Status: NEW → ASSIGNED
Attachment #227919 - Flags: superreview?(bienvenu)
Attachment #227919 - Flags: review?(bienvenu)

Updated

13 years ago
Attachment #227919 - Flags: review?(bienvenu) → review+

Comment 3

13 years ago
I just had a similar experience in SM 1.8 2006063009 OS/2. I tried to add 2 new lines to the existing 3 for my filter named "junk". On clicking OK, SM simply crashed. When I tried again on restart the additions were missing, but adding them again worked without a crash.
(Assignee)

Comment 4

13 years ago
bienvenu, can you give sr too?  Or declare the patch is to trivial for it?  :)

Updated

13 years ago
Attachment #227919 - Flags: superreview?(bienvenu) → superreview+
I see the issue described in comment 0 in Seamonkey 1.5a also.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060701 SeaMonkey/1.5a

No crash, the filter list window just goes blank after any change, such as 
move up, move down, New, or Edit.  

I found a faster workaround than closing and reopening the filter list window.
Just re-select the email account in the "Filters for" drop-down at the top of
the filter list window.  

At first I thought this might be a consequence of the workaround for bug 341595,
which is to disable the XUL cache.  But re-enabling it seems to have had no 
effect on this bug.  It merely reintroduced the crash of bug 341595.
(Assignee)

Comment 6

12 years ago
FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Still fully reproducible with Mozilla/5.0 
(Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060723 SeaMonkey/1.5a
while the XUL cache is disabled
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

12 years ago
works fine with current CVS

I have pretty low expectations that things work with XUL cache disabled.
IINM, the XUL cache should not be necessary for any other code to work correctly.
It should be seen as a performenace enhancement, not a necessary component.
(Assignee)

Comment 10

12 years ago
Ideally, yes.  Practically speaking, that's not the world we live in.  The ability to disable XUL cache exists for the purposes of development and debugging.  Search bugzilla for "disable XUL cache" for other fun things that happen.

Do you see the bug with XUL cache enabled?

Comment 11

12 years ago
I haven't had XUL cache enabled in a normal profile in probably at least 3 years, likely much more. I rarely have any kind of problem with a profile, and rarely use any SM other than nightly builds.
Felix, do you see this problem with your XUL cache disabled?  

Comment 13

12 years ago
Using today's OS/2 1.8 I tried adding, editing, running & deleting filters. Again I couldn't duplicate comment 0/summary, but I did crash on clicking OK to delete the test filter I had created on first open of the filters window today, little different from comment 3. My XUL cache is disabled, but I'm obviously not reproducing the disappearing window content. My filters do number more than fit in the pane space provided in the default size window.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041001 SeaMonkey/2.0a1pre

I've never had this problem (and I have quite a number of filters on my Global Inbox); but I don't know what "XUL cache" means. It is not mentioned in about:cache where I see:

- Memory cache
  Entries: 543, Max storage: 23552 Kib, In use: 26828 KiB (sic), Inactive: 0 KiB

- Disk cache
  Entries: 1989, Max storage: 51200 KiB, In use: 49866 KiB, Directory: <profile>/Cache

- Offline cache
  Entries: 0, Max storage: 512000 KiB, In use: 0 KiB, Directory: <profile>/OfflineCache

where <profile> is my profile (with full path).

Does this bug still happen on current trunk (2.0a1pre) builds?
(Assignee)

Comment 15

11 years ago
Tony, there's an option to disable the xul cache in the SeaMonkey debug->networking preferences.

Anyway resolving FIXED
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED
(In reply to comment #15)
> Tony, there's an option to disable the xul cache in the SeaMonkey
> debug->networking preferences.
> 
> Anyway resolving FIXED
> 

Ah, I see: thanks for the info. Anyway, this is one more bug "resolved" (for the moment at least) and I suppose that's the important thing.
You need to log in before you can comment on or make changes to this bug.