Squash annoying "offsetof" warnings in layout in gcc 3.4+

RESOLVED DUPLICATE of bug 450194

Status

()

defect
RESOLVED DUPLICATE of bug 450194
13 years ago
8 years ago

People

(Reporter: hwaara, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
PowerPC
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning])

When compiling trunk, there are a bunch of warnings like this:

/nsCSSPropList.h:325: warning: (perhaps the 'offsetof' macro was used incorrectly)

According to discussion in #developers, it's more or less a useless warning. One could write a configure test to compile with "-Wno-invalid-offsetof" for gcc 3.4+.
This could be usable for us, but it's possible that it's implemented in autoconf 2.4+ only (according to timeless)

http://autoconf-archive.cryp.to/ax_cflags_gcc_option.html
Blocks: buildwarning
Whiteboard: [build_warning]
Could not find any instance of this warning in the logs anymore. 
Hence closing this bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 450194
You need to log in before you can comment on or make changes to this bug.