Unable to select highlighted text in a textbox using "Highlight all"

RESOLVED DUPLICATE of bug 256989

Status

()

RESOLVED DUPLICATE of bug 256989
12 years ago
10 years ago

People

(Reporter: maikelkrause, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060703 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060703 Minefield/3.0a1

Now that bug 189039 is fixed we can highlight text in textboxes, but there seem to be a few issues with the "Highlight all" feature. Namely, once highlighted it can't be selected (except through a double/triple-click or CTRL+A). Also, when you delete part of the highlighted text, I'd imagine the logical behaviour would be for the text to get unhighlighted.

Reproducible: Always

Steps to Reproduce:
1. Open a site containing a textbox, such http://www.google.com/firefox.
2. Type a few words
3. Do a search for (part of) the text you just typed
4. Highlight all
Actual Results:  
Unable to select the highlighted text, nor able to place the cursor anywhere in the highlighted region.

Expected Results:  
Should be able to select it, just like you can with non-editable text.

Comment 1

12 years ago
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060702 Minefield/3.0a1 ID:2006070204 [cairo] 
Note: However, the quick find highlights the text but you can select it
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 256989 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.