Closed Bug 343547 Opened 14 years ago Closed 12 years ago

Target="_blank" opens new tabs also in size limited pop-up windows

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 377551

People

(Reporter: lc__fc-xx001xx, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060703 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060703 BonEcho/2.0a3

After setting the default to "Open links that would open new windows in: new tabs in the most recent window" the problem is now, that when you open a JavaScript driven pop-up with a limited size (e.g. height=500,width=300) every link within that window with a target="_blank" gets opened in a new tab in current tiny window instead of a new window.   

Reproducible: Always

Steps to Reproduce:
1. go to http://www.monzoon.net/index.php?cot=hsl&lang=en&hsl=zur
2. click on "Airport Zurich"
3. click on "click here for current coverage info"

Actual Results:  
New page gets loaded in new tab in tiny window, which makes handling impossible.

Expected Results:  
New page gets loaded in new window.
Reproduced in BonEcho/2.0b2 (2006081806) on Mac OS 10.4
But this should be Status: INVALID (Component: Tabbed Browser).

The actual result is the desired result: the third page is opening in a new tab as requested.  The third page loading in a new window would be surprising given your preferences.

To force specifically those links residing in windows with openers to open in new windows wouldn't make sense, and deciding based on a window's dimensions how to open other windows isn't great either.

However, I do wonder if the javascript-created window should pop up or go into a new tab (without the third argument to open() it would have gone into a tab instead).
It's not "my preferences" but the default preferences of Fx 2. Since the target group of Fx is the average user and not just the power user, the average user should be able to surf the web with the default settings without having to think first "have I got to select Open Link in New Window for this link."

The default setting "new pages should be opened in: a new tab" overrules the programmer's target="_blank", which has always been open in new window, without being able to handle all aspects of it correctly. That will lead to a lot of problems for a lot of people on a lot of pages. In my eyes this is a bug and far away from being invalid.
Component: Preferences

One thing I didn't realize is that Firefox 1.5 had three options for tabbed browsing (not forcing, and then two forcing options), while Bon Echo has only two.

For a while I thought Bon Echo just wasn't grabbing my 1.5 preferences, but your comment illuminated to me that I was on the default in 1.5 and now I'm on the default in Bon Echo, but their behaviors are different.

You're right: the default setting should be to open a new page in a new window.
I have experience this problem too. With my web site design I find this new setting in Firefox very problematic. I believe the target="_blank" should open a new window not a tab!!!

Apart from that I love the new FF.
I also think that this is Invalid.  If you set "new pages should be opened in a new tab" then you have just told Firefox to open all "_blank" links in a new tab of the current window, and this is what happens. You cannot have it both ways.
It's not that the user chose that setting but it's the default setting. If someone chooses a setting which has the effect that several pages are not handled correctly it's his/her problem. But if a browser has a default setting which overrules the code with the effect that several pages aren't handled properly anymore it's a bug in my eyes. 

Either change the default setting or find a solution for the current setting so that the pages are handled properly.
I have changed the default setting from 'New pages should be opened in a new tab' TO 'New pages should be opened in a new window' and every instance of a link with a target of _blank or _new opens the link a new TAB, not window as my preference setting specifies. That's a bug.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377551
You need to log in before you can comment on or make changes to this bug.