Closed Bug 343627 Opened 14 years ago Closed 14 years ago

"Save Page As" does not save files (css or images) embeded in css with url(...)

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 126309

People

(Reporter: p014723, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702

If you save "http://www.java.net" and opened the saved page, you will see that background color (grey) has disapeared on the top-left of the page.

If you manually save "http://java.net/css/extra.css" and refresh

Reproducible: Always

Steps to Reproduce:
1. Go to the site "http://www.java.net"
2. Save Page as...Web Page, complete to your hard disk
3. Open this saved page and compare to the web site

Actual Results:  
The page is displayed with a different look, I will focus on :
- no grey background on the top-left ("Get Involved", "Get Informed", etc.)
- no tabs on the top left ("My pages", "Projects", "Communities", "java.net"

Expected Results:  
The stored page should have been displayed exactly the same way as the original one :
- grey background on the top left
- tabs on the top left, cornered (the top left corner should be diagonaly cut)

I find out that the following files were not saved :
- "http://java.net/css/extra.css" (1)
- "http://www.java.net/images/nw_min.gif"  (2)
- "http://www.java.net/images/gray_bl.gif" (2)
- "http://www.java.net/images/gray_br.gif" (2)
- "http://www.java.net/images/gray_tl.gif" (2)
- "http://www.java.net/images/gray_tr.gif" (2)

(1) Manually retrieving this file recover the grey background on the top left.
see "http://java.net/css/main.css"
--> @import url(extra.css);

(2) Manually retrieving these files recover the "cornered" tabs on the top left.
see "http://java.net/css/extra.css"
--> background-image: url(/images/nw_min.gif)

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.