Crash after deselecting "Save Password"

VERIFIED WONTFIX

Status

SeaMonkey
MailNews: Account Configuration
P3
major
VERIFIED WONTFIX
18 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

({crash})

Trunk
All
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2000-04-03-09M14: NT4, Mac 8.5.1
Haven't tried Linux yet

Overview: After a series of steps a crash occurs after deselecting "Save 
Password" and clicking OK in Account Settings.

Steps to reproduce:
1. Open Account Settings and select a Server panel for any type of Mail account 
(i.e. POP or IMAP)
2. Select "Save password" checkbox and select the OK button.
3. Select the Mail account, select the "Get Msg" button
4. A password dialog appears so enter the Password and select the OK. Now the 
Master Password dialog should appear.
5. Without entering anything, Cancel out of the Master Password dialog
6. Open Account Settings and select the Server panel again
7. Deselect the "Save password" checkbox and select the OK button.

Actual Results: A crash occurs. (I've tried accessing Talkback but it reports an 
error when trying to retrieve the report)
Expected Results: No crash should occur.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → nbaca
(Assignee)

Comment 1

18 years ago
alot of these steps seem like they are unrelated. Can you try to narrow down
exactly what steps are causing the problem? maybe it's just cancelling the
master password dialog? 
there are general dialog problems today, so it might just be that closing any
dialog has a chance of crashing.
(Reporter)

Comment 2

18 years ago
The problem also occurs on Friday's 3/31 build.

I know this sounds disjointed but the crash happens after the Save Password 
checkbox is selected, Canceling out of the Master Password dialog and then 
deselecting the Save Password checkbox and selecting OK.

I tried:
A1. Select "Save Value" and cancel Master Password dialog: No Crash
- Get Msg
- In the password dialog I enter the password and select the "Save Value" 
checkbox.
- The Master Password dialog appears, select Cancel
- No crash
A2. Continue and now a crash occurs:
- Open Account Settings and select "Save password" and select OK.
- The Master Password dialog appears and cancel.
- Go back into Account Settings and deselect "Save password" and select OK and 
crash occurs.

B. Select "Save password" and "Check for new mail every # minutes"
- Open Account Settings and select "Save password" and "check for new mail 
every # minutes", select OK.
- Get Msg
- Enter password and OK
- Master Password dialog appears and select Cancel
- Go back into Account Settings and deselect "check for new mail every # 
minutes" and select OK. No crash.
- Go back into Account Settings and deselct "Save password" and select OK. 
Crash.

C. Select and Deselect "Save password" only: No crash
- In Account Settings select "Save password" checkbox and OK.
- Open Account Settings again, deselect "Save password" and OK.
- No crash, So not a problem with Account Settings dialog.

D. Select Save password, cancel out of password login: No crash
- In Account Settings Select "Save password", select OK.
- Get Msg so that password login appears and select Cancel.
- Open Account Settings, deselect "Save password", select OK. 
- No crash, so not a problem canceling from the password login.
(Assignee)

Comment 3

18 years ago
thanks for all the effort, this will definately help me track it down.
(Reporter)

Comment 4

18 years ago
Incident #: 7914315

Call Stack:    (Signature = si_RemoveUser 6885b1b6) 
si_RemoveUser               
[d:\builds\seamonkey\mozilla\extensions\wallet\src\singsign.cpp, line 892]
SINGSIGN_RemoveUser                            
[d:\builds\seamonkey\mozilla\extensions\wallet\src\singsign.cpp, line 916]
nsWalletlibService::SI_RemoveUser             
[d:\builds\seamonkey\mozilla\extensions\wallet\src\nsWalletService.cpp, line 
134]
nsMsgIncomingServer::ForgetPassword        
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgIncomingServer.cpp, line 
694]
nsMsgIncomingServer::SetRememberPassword      
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgIncomingServer.cpp, line 
777]
XPTC_InvokeByIndex                          
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
line 139]
nsXPCWrappedNativeClass::CallWrappedMethod     
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp, 
line 899]
WrappedNative_SetProperty                     
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
line 293]
js_Interpret               
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2339]
js_Invoke 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 696]
js_InternalInvoke 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 769]
JS_CallFunctionValue 
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2796]
nsJSContext::CallEventHandler 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 734]
nsJSEventListener::HandleEvent 
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 129]
nsEventListenerManager::HandleEventSubType 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
706]
nsEventListenerManager::HandleEvent           
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
850]
nsXULElement::HandleDOMEvent                 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3287]
nsEventStateManager::CheckForAndDispatchClick[d:\builds\seamonkey\mozilla\layout
\events\src\nsEventState
Manager.cpp, line 1600]
nsEventStateManager::PostHandleEvent         
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
759]
PresShell::HandleEvent                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3466]
nsView::HandleEvent 
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 811]
nsViewManager2::DispatchEvent                
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1354]
HandleEvent 
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent                     
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 502]
nsWindow::DispatchWindowEvent               
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 519]
nsWindow::DispatchMouseEvent                 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3139]
ChildWindow::DispatchMouseEvent              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3344]
 nsWindow::ProcessMessage                    
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2332]
nsWindow::WindowProc                        
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 677]
 USER32.dll + 0x1820 (0x77e71820) 

Comment 5

18 years ago
The real world way to hit this is to get annoyed with password manager dialog,
cancel it and go uncheck the box so it won't happen anymore?  Not sure I'd hold
beta2 for that, marking M17.  Please adjust if you don't agree.
Target Milestone: --- → M17
(Assignee)

Comment 6

18 years ago
well, I'm going to try to fix this for M16. crash is bad.
Status: NEW → ASSIGNED
Target Milestone: M17 → M16

Comment 7

18 years ago
Adding crash keyword.
Keywords: crash

Comment 8

18 years ago
Mail review recommends nsbeta2.
Keywords: nsbeta2

Comment 9

18 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17
(Reporter)

Comment 10

18 years ago
I cannot reproduce the problem because the "Save Password" checkbox no longer 
displays in the Server panel. I am not sure if this is by design or not.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Whiteboard: [nsbeta2+]

Comment 11

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. But due to last comments, marking as 
WorksForMe per PDT mtg.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Keywords: crash, nsbeta2
Resolution: WORKSFORME → ---
Whiteboard: [nsbeta2+]
Target Milestone: M17 → M18
(Reporter)

Comment 12

18 years ago
Reopening and assigning to myself until a decision is made. 

In the "Password Manager" spec for Mail 
(http://gooey/client/5.0/specs/mail/Misc/SingleSignon.html) it states:
"Users can store their password in the PM database using the Preferences: 
Account Settings dialogs. TBD".

It is still not clear whether the Save Password option will be in Account 
Settings. If Save Password is placed in Account Settings then I want to test 
this scenario so assigning to myself for now.
(Reporter)

Comment 13

18 years ago
Actually assigning to myself.
Assignee: alecf → nbaca
Status: REOPENED → NEW

Comment 14

18 years ago
Adding crash keyword
Keywords: crash

Comment 15

18 years ago
With the new decisions that were made today about how Password Manager will 
work, i'm not sure if the "Save my password" stuff belongs in Account Settings.

 If it was, the wording that Simone/Vera are working on for this checkbox 
(explaining if obscured or encrypted is currently enabled) would also need to be 
applied.  This wording has to change based on how the user has set the 
Obscure vs Encrption setting. 

Also, the additional "blue box" (explains how to enable encryption) that was 
discussed in the Password Manager meeting today would also need to be invoked if 
this was the first time the user decided to save a password.  

Since this is added complexity here, maybe we don't want the "Save my password" 
checkbox in Account Settings?  

Up to Steve Elmer how he would like to handle this.

Comment 16

18 years ago
Adding Alec to the CC list.

How important did we feel it was to have this here?  If we did it, it seems like
we could reuse the parts being created for the other places so the cost would be
pretty low.

Other opinions?
(Assignee)

Comment 17

18 years ago
We've never "invoked the blue box" from mail before, so there's no code to
reuse....
(Reporter)

Comment 18

18 years ago
The "Save Password" checkbox has been removed from Account Settings so I can't
duplicate the problem. Should this be marked Invalid?
Assignee: nbaca → alecf
(Assignee)

Comment 19

18 years ago
I'll mark it WONTFIX, since if we ever do put it back, the crash will probably
still occur.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 20

18 years ago
Verified WontFix.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.