History menu jumps around (disappears) since addition of new Recently Closed Tabs menu item

VERIFIED FIXED in Firefox 2 beta1

Status

()

Firefox
Menus
P1
major
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Adam Guthrie, Assigned: mano)

Tracking

({regression, verified1.8.1})

2.0 Branch
Firefox 2 beta1
regression, verified1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a3) Gecko/20060706 BonEcho/2.0a3

Steps to reproduce:
1. Open at least two tabs and close one of them.
2. Go to History and move your mouse down till you reach the "Recently Closed Tabs" menu item. 
3. Move your mouse back up over the listed History items.

Results:
The list of History items disappears and the menu "jumps" around.

Definitely a regression from bug 342700.
(Reporter)

Updated

12 years ago
Assignee: dietrich → nobody
Component: Tabbed Browser → Menus
QA Contact: tabbed.browser → menus
(Reporter)

Updated

12 years ago
Assignee: nobody → dietrich
Just a note that this occurs on WinXP also, but *not* on Mac.
Status: NEW → ASSIGNED

Comment 2

12 years ago
*** Bug 343949 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
I see the same thing in Mozilla/5.0 (rv:1.8.1a3) Gecko/20060707 BonEcho/2.0a3 on XP and 2003.

I described it as follows in bug 343949.
The History menu shrinks and loses the 10 item recent history list, after the
user touches and expands the Recently Closed Tabs option.  If the user quickly
moves over the Recently Closed Tabs option (without it expanding), then no
shrinking occurs.  (The shrinking is caused by the loss of the 10 item recent
history list.  Navigating to another menu and then back to the History menu
causes the 10 item list to be repopulated.)  The menu shouldn't shrink and
disappear out from under the mouse cursor.

Reproducible: Always

Steps to Reproduce:
1. Click on the History menu
2. Click on the Recently Closed Tabs entry to expand it
3. Put the cursor on another History menu entry (like 'Show in Sidebar') and
see it shrink in < 1 second right before your eyes.

Expected Results:  
menu shouldn't shrink and disappear out from under the mouse cursor

Comment 4

12 years ago
Created attachment 228515 [details]
1 - viewing Recently Closed tabs menu entry

Comment 5

12 years ago
Created attachment 228516 [details]
2 - viewing Show in Sidebar History menu entry

Comment 6

12 years ago
Created attachment 228517 [details]
3 - viewing the History menu after shrinking

Updated

12 years ago
Attachment #228515 - Attachment description: viewing Recently Closed tabs menu entry → 1 - viewing Recently Closed tabs menu entry
Assignee: dietrich → bugs.mano
Severity: normal → major
Status: ASSIGNED → NEW
Flags: blocking-firefox2?
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → Firefox 2 beta2
Status: NEW → ASSIGNED
Attachment #228589 - Flags: review?(gavin.sharp) → review+
Target Milestone: Firefox 2 beta2 → Firefox 2 beta1
mozilla/browser/base/content/browser.js 1.658
mozilla/browser/base/content/browser-menubar.inc 1.97

Will get post-facto review on this once mconnor is back.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Tested patch on Mac. Definitely blocks Firefox 2, and based on others' assertions of safety (dietrich?) we should probably take this for today's respins.

Mano: mconnor's not going to be back until tonight; can you think of another appropriate sr? ben? vlad? bryner?
Flags: blocking-firefox2? → blocking-firefox2+
(In reply to comment #9)

As i noted on IRC, I'm confident enough in this patch (and gavin's review) to only look for a post-facto peer review on it.

This cannot bake on trunk as the bug doesn't affect places-enabled builds.
(In reply to comment #9)
> Tested patch on Mac. 

Did you see the bug on Mac? I was not able to reproduce it on Mac, only Windows (didn't try Linux).

I tested the patch on Windows; it works, and seems safe, as those functions don't have any other callers (that I could find).

Updated

12 years ago
Attachment #228589 - Flags: approval1.8.1? → approval1.8.1+
I asked beltzner to test it on Mac to make sure it does not regress the go menu behavior (onpopupshowing/onpopuphiding are dispatched differently on mac).
1.8 branch:
mozilla/browser/base/content/browser-menubar.inc 1.57.2.37
mozilla/browser/base/content/browser.js 1.479.2.163
Keywords: fixed1.8.1
Comment on attachment 228589 [details] [diff] [review]
patch

(clearing sr)
Attachment #228589 - Flags: superreview?(mconnor)
(Reporter)

Comment 15

12 years ago
Verified FIXED using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1 → verified1.8.1
You need to log in before you can comment on or make changes to this bug.