Enable official branding and set version to Firefox 2 Beta 1 for upcoming release

RESOLVED FIXED in Firefox 2 beta1

Status

()

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mtschrep, Assigned: rstrong)

Tracking

({fixed1.8.1, late-l10n})

2.0 Branch
Firefox 2 beta1
fixed1.8.1, late-l10n
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 3 obsolete attachments)

65.64 KB, image/png
Details
66.23 KB, image/png
Details
3.04 KB, patch
bryner
: superreview+
mtschrep
: approval1.8.1+
Details | Diff | Splinter Review
187.03 KB, image/tiff
Details
276 bytes, application/octet-stream
rstrong
: review+
mtschrep
: approval1.8.1+
Details
161.96 KB, image/tiff
Details
10.63 KB, patch
rstrong
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
For the upcoming beta releases wewant to enable official branding -- to encourage wider testing and feedback. The official branding will be "Firefox 2 Beta 1"

Bug 306020 documents this procedure for 1.5 which should be mindful of those changes and problems/regressions caused.
(Reporter)

Updated

13 years ago
Flags: blocking-firefox2+
(Reporter)

Updated

13 years ago
Target Milestone: --- → Firefox 2 beta1
(Reporter)

Updated

13 years ago
Assignee: nobody → robert.bugzilla
On the build side, looks like the only change we need is adding --enable-official-branding to the mozconfig.

The tinder-config.pl is already using Firefox as the ProductName and Mozilla as the VendorName (on linux and win32); on Mac, ProductName is BonEcho, so I'm assuming I'll have to change it back to Firefox when that mozconfig flag gets flipped for all three.

Rob: let me know if you need/would like to review those configs.
Taking a quick look at the patches that were landed on bug 306020, I see that  ...

attachment 194714 [details] [diff] [review] 
 - changes the numeric version number to "Beta 1" in aboutDialog.xul, browser.xul and config.it
 - changes "Deer Park Alpha 2" back to "Deer Park" in several locations

attachment 195057 [details] [diff] [review]:
 - changes string in old installer

attachment 195095 [details] [diff] [review] and 195102 were hacks that seem to have been fixed more permanently by bug 307299, Mark, can you give me a confirmation or let me know if I need to do something else here? 

So, the required changes we need for this bug are:

1. get preed to flip the mozconfig to use --enable-official-branding
2. the same changes to aboutDialog.xul and browser.xul
3. update the version number in browser/app/module.ver and browser/config/version.txt
4. :rs needs to make sure his installer strings also use human-readable "Beta 1" suffixes, and change the default install dir to "\Program Files\Mozilla Firefox 2" on Windows

Preed's offered to do (1) in comment 1
I can put together a patch for (2), (3) and whatever else Mark tells me I need to do tonight or (more likely) tomorrow morning EDT.
Rob needs to put together a patch for (4)
cc'ing l10n; I don't really want to rev the entities in browser.xul and aboutDialog.xul for what's really a temporary change to using a suffix; however, the localization teams should know that if they want a localized version of the "Beta 1" suffix (or if they need to make it a prefix) this patch will show them where to make them.
Keywords: late-l10n
(asking shaver for review to get it done in EDT, and 'cause benjamin and dbaron are on vacation today)
Attachment #228392 - Flags: review?(shaver)
Comment on attachment 228392 [details] [diff] [review]
adds "Beta 1" to aboutDialog.xul, browser.xul and updates version number

Actually, I bet it would be best to get Mark to review this as well to ensure I'm not missing any Mac changes that I should be making ...
Attachment #228392 - Flags: superreview?(shaver)
Attachment #228392 - Flags: review?(shaver)
Attachment #228392 - Flags: review?(mark)
Summary: Enable official branding and st version to Firefox 2 Beta 1 for upcomming release → Enable official branding and st version to Firefox 2 Beta 1 for upcoming release
Summary: Enable official branding and st version to Firefox 2 Beta 1 for upcoming release → Enable official branding and set version to Firefox 2 Beta 1 for upcoming release
(Reporter)

Comment 6

13 years ago
Rob strong should weigh in here as well since he thought some of the changes in bug 339734 would remove the need to manually change this stuff for the installer.
Status: NEW → ASSIGNED
(Reporter)

Comment 7

13 years ago
Also - not sure we need the change to the AboutDialog.   With just the other changes it should say version 2.0b1 I believe.   Which imho is just fine.  
I just got r+ from sspitzer on bug 339734 and a+ from beltzner for the branch patch. I am going to let it cycle on the trunk, check it into the branch, and verify a cycle there as well. I'll submit a patch for any remaining items I have for this bug tonight.
Posted image Wizard page 1
Bah... adding Beta 1 messes up the alignment of the first line of the wizard. I can probably change the font size for this text. I am going to do more testing and then I'll submit a patch for the branding changes, etc.
I forgot to add 2.0 :P This looks better
Posted patch Win32 Installer patch (obsolete) — Splinter Review
This adds a new define so we don't write Mozilla Firefox Beta 1 to registry keys and shortcut names in the cases we shouldn't such as:
Software/Mozilla/Mozilla Firefox/version (AB_CD)/
Start Menu\Mozilla Firefox Beta 1\Mozilla Firefox.lnk
and other places

The patch does the following for issues where there is no good answer for supporting a side by side install:
* The default install directory is Mozilla Firefox 2.0 Beta 1
* I've set the names of the shortcuts in QuickLaunch and on the Desktop to Mozilla Firefox 2.0 Beta 1.lnk so as to not overwrite an existing shortcut of the same name.
* I named the start menu directory Mozilla Firefox 2.0 Beta 1 and left the shortcut names as Mozilla Firefox.lnk
There can only be one StartMenuInternet registry key (e.g. the system generated shortcut on the left top of the startmenu. There is no solution to overwriting and the installer will overwrite that for an existing install of Firefox. We could disable the overwriting for Beta 1 or leave it as is.

I could add another value of Mozilla Firefox 2.0 without the Beta 1 for the install directory, startmenu directory, and shortcut names to shorten them though this would add additional complexity.
Attachment #228411 - Flags: review?(sspitzer)
Attachment #228411 - Flags: approval1.8.1?
preed, I can review the tbox configs though I am only familiar with them in regards to the win32 installer which should be good to go with this last patch.

Comment 13

13 years ago
Comment on attachment 228392 [details] [diff] [review]
adds "Beta 1" to aboutDialog.xul, browser.xul and updates version number

r+ in that there's nothing here that will hurt the Mac build.
Attachment #228392 - Flags: review?(mark) → review+
This only adds "Beta 1" to the window title string, minimizing change as per schrep's comment. I'm really fine either way, since I think version 2.0b1 is pretty understandable in the About... window.

Carrying a=mark over from previous patch, changing sr to vlad as he's actually a browser peer :)
Attachment #228392 - Attachment is obsolete: true
Attachment #228431 - Flags: superreview?(vladimir)
Attachment #228431 - Flags: approval1.8.1?
Attachment #228392 - Flags: superreview?(shaver)
Attachment #228392 - Flags: approval1.8.1?
er, bah, r=mark, not a=mark :)
Comment on attachment 228411 [details] [diff] [review]
Win32 Installer patch

r=sspitzer
Attachment #228411 - Flags: review?(sspitzer) → review+
(Reporter)

Comment 17

13 years ago
Comment on attachment 228411 [details] [diff] [review]
Win32 Installer patch

I believe cbeard wanted it "Firefox 2 Beta 1" rather than "Firefox 2.0 Beta 1"
(Reporter)

Comment 18

13 years ago
Comment on attachment 228411 [details] [diff] [review]
Win32 Installer patch

Approved with change from 2.0->2
Attachment #228411 - Flags: approval1.8.1? → approval1.8.1+
(Reporter)

Comment 19

13 years ago
Comment on attachment 228431 [details] [diff] [review]
adds "Beta 1" to browser.xul and updates version number

Approved for landing once it has been review a+
Attachment #228431 - Flags: approval1.8.1? → approval1.8.1+
Attachment #228431 - Flags: superreview?(vladimir) → superreview+
Comment on attachment 228411 [details] [diff] [review]
Win32 Installer patch

This patch has been checked in to the 1.8.1 branch
Attachment #228411 - Attachment is obsolete: true
Comment on attachment 228431 [details] [diff] [review]
adds "Beta 1" to browser.xul and updates version number

Patch checked in to the 1.8.1 branch
on my mac, robert and I have built a fresh, branch build with "ac_add_options --enable-official-branding" in my mozconfig.

one problem I am seeing is with the "Application" menu (to the right of the Apple).

it still says "Bon Echo".  Note, the Help menu has the right thing as does the about dialog.

here comes a screen shot.
thanks to asaf and mscott, we know where this is coming from now.

Firefox.app/Contents/Resources/en.lproj/InfoPlist.strings

working backwards to figure out what we need to fix.
asaf tells me over irc:  "the file is UTF16ed so we can't just "sed" it"
see http://lxr.mozilla.org/mozilla1.8/source/browser/app/Makefile.in#319, where we rsync (but don't "sed", as asaf explained) the contents of the macbuild/Contents/Resources/English.lproj directory
robert sent me a modified version of this utf16 file (where he replaced "Bon Echo" with "Firefox" using a utf16 friendly editor) and I rebuilt on the mac, and the problem is now fixed.

I'll attach a new screen shot.
I got a verbal r+ from sspitzer and a verbal a+ from schrep to land this
Attachment #228481 - Flags: review+
(Reporter)

Updated

13 years ago
Attachment #228481 - Flags: approval1.8.1+
(Reporter)

Updated

13 years ago
Keywords: fixed1.8.1

Comment 31

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060708 BonEcho/2.0b1 ID:2006070805

20060707 respin Nightly is named "Firefox",
20060708 Nightly is "Bon Echo".
Why? What Happenes?
The release tinderbox has ac_add_options --enable-official-branding, the nightly tinderbox does not.

That may be on purpose, though, I'm not sure if nightlies are supposed to have official branding on, and if the non-official nightly branding should be moved over from BonEcho to Firefox.
Installer changes checked in to trunk. resolving -> fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Comment on attachment 229516 [details] [diff] [review]
Rename back to Bon Echo for Mac OS X (1.8.1 branch only)

r=sspitzer
Attachment #229516 - Flags: review? → review+
Comment on attachment 229516 [details] [diff] [review]
Rename back to Bon Echo for Mac OS X (1.8.1 branch only)

1.8.1 branch only - changes Firefox back to Bon Echo for Mac OS X's menubar
Attachment #229516 - Flags: approval1.8.1?
Comment on attachment 229516 [details] [diff] [review]
Rename back to Bon Echo for Mac OS X (1.8.1 branch only)

No longer needed now that bug 343931 has been fixed
Attachment #229516 - Attachment is obsolete: true
Attachment #229516 - Flags: review+
Attachment #229516 - Flags: approval1.8.1?
You need to log in before you can comment on or make changes to this bug.